Download

Need help with a dedicated server (ready to pay)

Hello community,
I have my own game, but I faced with problem:
https://answers.unrealengine.com/questions/1042498/view.html
I can’t find any clue, this is my last step before I can show my game to investors, please help me with this issue.

I ready to pay for this help (if you’re interesting, please contact me: schepetkov.dm@gmail.com)

Also, I’m looking for a senior UE4 C++ developer, on salary, who likes turn-based strategies :slight_smile:

Game: Kill King is a free-to-play online game. - YouTube

Thanks!

From the screenshot in your answerhub post it looks like you’re passing the listen option wherever you’re calling OpenLevel or similar. Make sure you don’t pass this when running as a dedicated server as these conflict with each other. You can either run the game as a dedicated server or a listen server but not a mixture of both.
Depending on how your dedicated server behaves at startup you should be able to set either a different startup map for the dedicated server in the project settings or pass the listen option conditionally depending on the result of UKismetSystemLibrary::IsDedicatedServer.

Hi @UnrealEverything, Sorry for later reply, thank you for trying to help me. I removed

listen?.
But now I see strange characters in my sting, and server shutdown.

I wanted to try debugging, why does it get there like this: Is there anyway to debug a dedicated server using Visual Studio 2015? - UE4 AnswerHub
But I crashed when I tried:

I’m not quite sure where to get the symbols? I downloaded the symbols for 4.26 editor, but the server was built from source. Can you tell me what I’m doing wrong? Where do I get the symbols? I have never debugged a dedicatee server :frowning:

I was able to start debugging, but I still can’t figure out where I got the Chinese characters from.

The format string has 4 instances of %s format specifier but it looks like the last argument is commented out, meaning only 3 are actually passed in. I’m not familiar with the internals of FString::Printf but this is probably undefined behaviour. It appears to format the fourth parameter from invalid memory which happens to be some chinese characters. Either remove one of the extra %s specifiers or just pass an empty TEXT("") argument instead.

Thanks, this fix the issue, but server still shutdown :frowning:

I fixed, the problem was trivial I did not open the map, after a successfully created session. :grinning: