Download

Need help for building the engine

Hi everyone,

I wanted to work on the light system of Unreal but I’m having troubles to build the engine from the source code so I need your help.
I have cloned the code from github (4.16 branch), but when I’m building in VS I’m having these errors :

‘SetPipelineState’ : name qualified non conform in the declaration of a member
‘SetPipelineState’ : name qualified non conform in the declaration of a member
Failed to produce item: C:Users\user\Documents\UnrealSourceCode\UnrealEngine\Engine\Plugins\Runtime\OculusRift\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-OculusRift.lib
The command "…\Build\BatchFiles\Build.bat UE4Editor Win64 Development -waitmutex’’ has stopped with the code 5. Make sure to have the rights to execute this command.

(I linked an image with more informations, sorry some lines are in french but I translated them above)

If I run the build anyway I got an error : it can’t load the Oculus plugin and ask me to install it or disable it for the project. The issue is that the Oculus folder does not exist in the plugin folder and as I don’t launch any project but just the engine I don’t know how to disable the plugin.

Thank you for your help and happy game developing.

You need 4.16 specificaly? You can’t download the last version (branch release, version 4.16.1)?

I have the identical issue with 4.14 as well.

4.16.1 doesn’t compile with VS 2017 as is, you have to make this one small change:

3854d9bc6c64c269f698d6fe7455b2fec5f4b2b0.png

Well it worked !!! Thanks a lot :slight_smile:

(a bit surprised that 4.16 doesn’t build with VS 17 as the documentation advise to use VS 17)