Download

Need Camera help with rolling starting project.

So i’m having an issue with getting a camera set up in blueprints with the Roller starting project. I have searched the forums, and online a LOT, and come up empty handed, I watched the video
on youtube of the third person camera, with the button reset, This, but he is using the third person example and a Character(class) BP doesn’t work for me (i’ll explain in a few).

Problem is that the Camera doesn’t want to work right, it rolls (yaw = side to side, pitch = up and down) when you yaw it then pitch then yaw again. If you move the camera in a circle the camera rolls. so I fixed that with a BP that on tick resets the camera roll. To move the camera I set up something very simple, its not elegant but it does the job, see here but the problem now is that the camera “avoids” looking down onto the ball, the best I can explain it is imagine a cone whose point is on the ball and its standing on top of the ball, that cone is an avoidance zone.

If I pitch (press up) to make the camera go straight up, it veers around the cone and I wind up at an angle. Moving the camera around the ball also poses problems, but they are harder to describe.

Some may ask why I don’ just use a character(class) BP, like in the third person example. Well I tried that, and the camera worked great! its just that I couldn’t get my ball to move for the life of me. I tried copying the BP straight and replacing the skeletal mesh with nothing, and adding the ball, and I tried adding torque to the ball, and it just wouldn’t move. (I also had trouble with the camera because the ball was rolling)

The thing i’m looking for, is the camera movement of the third person controller, while using a rolling ball. That’s it really. Do I need to make a “ball” character, with a bone in it and animate it for everything to work correctly? Or do I need to make a new class in C++ to get things right? I was kinda hoping I could get this right in BP, BP’s are really cool and easy.

here is my complete camera BP that i’m using now. it “works” but it sucks, can anyone here help me?
Sorry about the blurriness, that’s the snipping tool hard at work.