Download

nDisplay error when using picp_mesh

I have been having some issues which appear to be isolated to my setup but i cannot move past.

I followed several demos, however they natively fail with the same error, suggesting the CFG file is not being read, even though i can see it being accessed and parsed in the console when the project boots up.

The error specifically, in the editor is:

LogPicpProjection: Error: Viewport ‘vp_1’ with ‘picp_mesh’ projection not found

and it happens when i connect the Begin event to the Viewport mesh process. I can remove this, no more error but then it wont build on ndisplay. Something is wrong but i cant see it and losing hair.

I have also followed like many people, the following tutorials:

Lastpixelstudios : https://www.youtube.com/watch?v=gec9idRXpxo
Ben Kidd’s: https://www.youtube.com/channel/UCh_…1D3WJeFS1FPuhw
Vitalii Boiko’s : https://drive.google.com/file/d/1QZQ…RhlzgAVN9/view

The Ben Kidd example works just fine, with camera tracking too across 1 PC + 2 screens. Also tested briefly with 2 PC + 1 screen each on network, and things worked fine also.

However when i add a blueprint, which they refer to as Warp (under different names) things seem to fail, as if there is a fundamental problem with my setup. I have tried the same thing across different versions of Unreal Engine (4.25.1 + 4.25.3), across 3 different computers (one being a bootcamp on mac just to rules out more envirnoments) and all return the same error at the same time. I am missing something, and need help, as its confusing enough to set all this up when things Are working. All are on Windows 10 Home but i understand unreal has no requirement to be on professional.

I can repeat this by using the nDisplay template and just adding the above screenshot code into any blueprint that launches when the game starts.

The CFG file has the vp_1 pointing to a projection which has type picp_mesh and i can see the line being parsed in the console with ‘ok’ under it, suggesting its been read and life is fine

I am hoping maybe an engineer can see this and just know what this error relates to and the simple thing i need to look into.