Navmesh settings for maximum accuracy

I have been testing out NavModifierVolumes and noticed that the paths the pawn takes are obviously not the shortest. Given a straight path with nothing intervening the path takes detours to the left or right that are not insignificant. When the volumes are involved these detours seem to happen at the border of the volume. I assume this is something to do with the polygons the navmesh uses but I can’t find any settings that increase the accuracy. I don’t care if it takes more computation, I just need the most accurate path the navmesh can give.