Download

My Games Launcher is broken and I can't use AnswerHub. Any help?

These are killing me.

First problem: AnswerHub doesn’t work when I’m signed in.

This one is the weirdest, and I can’t work around it any more. If and only if I am logged in, I get this error message on Answerhub:

&stc=1

This started yesterday morning. What gives, Epic?

Second problem: EpicGamesLauncher positively refuses to sign in.

This started earlier today. What a weekend.

I was signing in to the editor, and got stuck logging in - it was an infinitely spinning circle loop and no actual sign in.

I closed it and tried reopening the editor. The .exe apparently got corrupt just then, and I had to uninstall/reinstall the editor.

However, a new sign in problem has arose from the ashes: whenever I click the sign in button, the password field becomes blank, and it claims I have invalid credentials. I assume this is because the password field is clearing. And yes, I know I’m entering the password in right. The only other problem I can imagine is that I’m “signed in on too many machines.” Right now I’m logged on to the forums on my computer, and I was logged in on my phone (some reason, being logged in on the forums counts against you being able to log in to the launcher.) I have since logged out of my phone, the only other device I have logged in on, and *still can’t sign into the Launcher.

** Update: Launcher works now somehow. Answerhub still down.***

Help me!

AnswerHub will function again in the next couple of days.

Hi everyone,

We may have a fix implemented for this error. Please try logging into answerhub again, if you still have the error, please post on the linked forum thread here so we can continue working towards a solution.