Multiplayer - Client Instance Specific Visibility/Rendering

I have X amount of clients connected to a dedicated (authoritive) server. Using blueprints.

Different aspects of the level or other players / NPCs need to not be rendered by specific clients when an actor belonging to that client is overlapping the object.

How do I turn off the visibility for that client only?

Currently setting not visible for any one client seems to make it not visible for all clients. Not sure what I’m doing wrong. If I can set the rendering in the material instance that may work.


How ridiculous, I didn’t notice for debugging something else the relevant asset was no longer set ‘relevant to owner only’. It’s sorted now.

It seems like the more work I do, the less work I do because I get tired and make mistakes hah.