Download

Multi User Viewer Template: VR hands and navigation don't work

Hi,

I’m new with Unreal Studio. We are Architecture firm testing Unreal Engine and have been working with the Multi User Viewer template. For the most part it goes well, but we couldn’t figure it out the VR mode. When we plug in a VR headset (Vive or Mixed-Headset), we can see the world but the hands and the controller do not show up. So VR users can’t move/navigate around at all. At the same time the mouse and laser pointer still work so we thought it got stuck in desktop mode.

In the Unreal documentation about the particular template, there is this snippet about checking “VR Mode” in the gamemode blueprint but this doesn’t exist with our copy of Unreal Engine. There is a VRmode checkbox in “BP_MultiUser PlayerController” blueprint, but checking that does not change anything.

Is there any help that we can get on how to enable VR mode properly on this template?

Thanks

In the beginning menu after entering your name, do you switch it from “Desktop” to “VR” for the input device? Does your scene have a Navigation Mesh in place?

Hi Lewis,

Thanks for your response. So to rule out my additions causing problems, I just did a fresh new Multi User Template project. I was hoping to be able to use VR in the editor’s VR Preview, is it possible? I did create a Windows x64 package and run it with our Vive machine. It did give us the option to choose VR, but when I click next the program crashed with this error:
Assertion failed: !SteamVRHMD->VRCompositor [File:D:\Build++UE4\Sync\Engine\Plugins\Runtime\Steam\SteamVR\Source\SteamVR\Private\SteamVRSplash.cpp] [Line: 54]

Thanks

Not sure with Vive but Mixed reality controllers tend to misbehave unless configured correctly. Epic’s implementation of Mixed Reality doesn’t appear to be complete right now meaning some controls on MR controllers are missing. Have had the most success using SteamVR rather than Mixed Reality and using SteamVRInput plugin to map the missing controls.

Also have found that using Mixed Reality rather than Steam VR means that edit in VR is greyed out - again using Steam VR for a MR headset/controller appears to fix this.

Hi David,

Thanks for the response. Yes we kinda realized that the Mixed reality not working very good, but for our test just exporting a bare Multi User Template we were not using that (we use Vive / SteamVR), and the issue still persist (when exporting to x64 exe). I think there is another person having the same issue in the forums but no reply on his issue yet.

As I mentioned in my original post, in the tutorials there is this checkbox “VR Mode” that does not exist in the latest build (4.22), do you know where they move it to?

Regards,

Hi - I found that the Unreal Academy video tutorials from Epic on a simple Architectural scene were really helpful as they walked you through creating a bare bones VR Pawn. I’d suggest checking it out.