Download

Multi-Trace ignoring certain components(HISM)?

Hey all I’m trying to make a simple trace macro that will trace for walls and if it detects any it will output true, otherwise; false.

When the macro starts it just takes a location and traces.

If it hits an HISM(It always will) then add to array.

Completed will then take the array and iterate through.

The new foreachloop will set the “Valid Column?” bool to true and then check the instance for the tag.

If component tag = “Wall” or “Column” then mark bool as false.

If component tag != then false and do nothing.

When the loop finishes it gets the bool and finishes the macro.

Function outside places columns based on bool.

I’m like 80% sure this setup should work but there is a problem… My traces ignore the walls. I don’t know why, the floors and other columns get hit(they are all HISMS of this bp actor the macro exists in).

The collisions for all HISMs have the exact same setup and settings. The trace is big enough to hit the walls. It’s all setup correctly, it is either some sort of bug or I’m messing up something here.

This post has been sitting on ue4 answerhub for like two weeks with no fix yet. I would absolutely love for someone to tell me what I’m doing wrong there is no reason my traces should be ignoring my walls, but they are and I absolutely can’t move forward on my project until this is fixed. Any help appreciated.

Post the trace setup and the collision settings for your walls & columns.

I took my trace function out of a macro and just put it into the event graph and now it works. This definitely has to be a bug as the function, collisions nor the HISM have changed in any way. The trace will not work when in a macro, but will when in event graph.

Oh well, not gonna ruin anything and now I can continue my project, just an annoying very niche engine bug. Thanks all for the help and responses.