Download

Modelled a room, sun shines in

Hi,

so I am new at UE. I created my kitchen in Blender. All the normals of the faces are pointing into the room. Now I import this room to UE. And now some strange thing happens:

As I want to have, the walls are invisible from the outside (the normals are pointing to the inside), from the inside they are visible. But what I don´t want to have:
The sunlight shines through the walls into the room. and only the walls that are pointing to the sun are casting a shadow…
Does this mean that I have to create faces with two normals?

best regards

Artur

Hi

In the material Editor you have the option for “Two sided” Material.
I would create the walls with 2 faces, this should be the best option :wink:

There is also an option in the model that is “Doubled Sided Geometry”. I heard this will eliminate the problem.

For buildings you need to have geometry blocking the outside, it’s good to have some space between the inside and outside (thick walls) to avoid shadow bleeding.