Download

MMO Starter Kit

i just wanted to say thanks for keeping this updated!
this project started my journey in UE4 in 2015, and i still use it for inspiration.
best wishes!

for any one that is interested you can take a look at what we are doing with the kit. here. Redirecting...

https://scontent-den4-1.xx.fbcdn.net/v/t1.0-9/71498779_430323600930883_6183182090670964736_o.jpg?_nc_cat=108&_nc_ohc=krXsAi7DP1YAQnylSneXKLlrTDWZR_zLbmCLAajKCfR8TO7qtRT_19oLg&_nc_ht=scontent-den4-1.xx&oh=7e51d5a0cd510264a140471f5819f6e7&oe=5E722FC2

https://scontent-den4-1.xx.fbcdn.net/v/t1.0-0/p180x540/78655648_472521490044427_8647243341357907968_o.jpg?_nc_cat=110&_nc_ohc=re_cE7u9EmgAQkokHGoufJEWwhyvkgJHwlW6QTCzRQ4z21ZkKTWjeeEPg&_nc_ht=scontent-den4-1.xx&oh=853c09e731fd19bc3f33a431b0699e1d&oe=5E7DF805

That is really pretty

Good Day. i have a question for codespartan that concerns the chat. we are still using the 4.22 engine. we have not chosen to make the switch to 4.23 as of yet. i was perusing the source for the chat and noticed the version of the newtonsoftjson.dll included with the chat engine is dated 3/14/16 and the version included in the unreal source is dated 11/22/19. could this be the source of the problems with the chat engine? i am guessing the parts of the mmokit when compiled would be using the newer version, but the already compiled component of the chat is using the older version. just curious. additionally the version that appears in the visual studio in the source code seems to point to a version dated 1/28/16.

update on my previous post. i copied the chat server source to another folder. i opened the sln and did the nuget update on the json package. i rerolled the chat with the new version and while it does run fine. it still stalls. =/ it did give me the new json with the .exe like it should and they launch and run great. but no bonus on the stall.

4.24 version is out:

  • no changes

If you’re updating your project yourself:

There’s a known bug, where the game server timeouts from the chatserver after a couple of days of being online. I’m investigating it. Otherwise the new chat server ran perfectly for a couple of months without needing to be rebooted.

hello guys
anyone worked on server instancing or have any tutorial related to that?

UE4.24

LogSockets: Warning: Tried to bind address with protocol None to a socket with protocol IPv4
LogUDPCommand: Error: Failed to bind listen socket to addr () for Matchmaking UDP

// InitSocket()
//
// Task: Init everything :slight_smile:
//
bool UMatchmakingUDPComponent::InitSocket(int32 port)
{
// Prepare Temp Variables
bool bSuccess = false;
ISocketSubsystem* SocketSubsystem = ISocketSubsystem::Get(PLATFORM_SOCKETSUBSYSTEM);
ListenAddr->SetPort(port);

// Create the needed Socket
ListenSocket = SocketSubsystem->CreateSocket(NAME_DGram, TEXT(“UDP Matchmaking”), true);
if (ListenSocket == NULL)
{
UE_LOG(LogUDPCommand, Error, TEXT(“Failed to create listen socket for Matchmaking UDP”));
return false;
}

// Set config
ListenSocket->SetReuseAddr();
ListenSocket->SetNonBlocking();
ListenSocket->SetRecvErr();

// Try to bind
if (ListenSocket->Bind(*ListenAddr))
return true;

// Binding failed -> Log Error
else {
UE_LOG(LogUDPCommand, Error, TEXT(“Failed to bind listen socket to addr (%s) for Matchmaking UDP”), *ListenAddr->ToString(true));
return false;
}
}
// InitSocket()

Hello, can I use visual studio 2019 for MMO Starter Kit 4.24, Or do I have to use 2017?

you can use both but recommend use the one in doc

I purchased the 4.23 version of the MMO Starter Kit, do I need to pay for each MMO Starter Kit Upgrade or how do I get the 4.24 update?

You’ll always have access to the latest version on Sellfy as long as you haven’t lost your sellfy account.

Good evening @CodeSpartan

Issue #1
I’ve tried about 3 times to upload the game to the ftp.
It does “work” partially, as I can download the game from the launcher, however not the big .pak file.

I also receive this error when uploading (GameUploader) the game, but yet, I can see the file uploaded in the ftp folder.

how can this be fixed? I’ve uploaded two times the build, with the same error.
when I use thelauncher, it will download everything except the pak file, which is 6gb (even though it shows on the ftp folder and is “downloading” the pak from the launcher, as it says the whole game is 6.2gb)

To be honest, I can even download the file from the FTP and it has the same size, as my build before uploading, so it could be uploading successfully (regarding giving that error). Nevertheless, when downloading from launcher there seems to be an issue where that pak file downloads, but does not end up in the game folder (unzip issues? too big? there is no error on this part)

Note: this initially happened in the VPS I set up, then I tried doing it on a webhost (bluehost.com) and happened the same.

PS: i uploaded another project for test, with lots of file no bigger than 10mb and after 20m uploading, same error occured, so its not because of the file size.

Issue #2

No, I have not modified any source, except for the launcher images.
When I do a new “patch” and deploy it, I enter the website.

I noticed this “slash” to be probably wrong?

I ask because it says “deploy successfully” however when I try to download the patch file, it gets stucked. Guess what? Remaining Files: 4
which I believe are these four from the deploy log in the website ftp.

The first upload/deployment is successfully. Then I just open the game, add a new texture, or change a texture in the map (ThirdPerson default), rebuild, open gameuploader, uploads the files, and when I hit the deploy, it always (or the third time) shows these error.

Running deployment
Archives extracted successfully.
Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
-> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_D.m.ubulk.7z
Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
-> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_D.uptnl.7z
Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
-> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_N.m.ubulk.7z
Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
-> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_N.uptnl.7z
ZipSize.xml created successfully.Update deployed successfully.
Back to admin panel

The FTP folder created this new archive, error_log:

[22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267
[22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267
[22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267
[22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267

After this error, the launcher just stops working: it would stop at 17% of a download, getting stucked/not downloading anymore. No matter what.

regards

hello Namesis. i might be able to give you some insight here.

Issue #1
I’ve tried about 3 times to upload the game to the ftp.
It does “work” partially, as I can download the game from the launcher, however not the big .pak file.


we ran into this very same issue with out uploader at first. the issue i believe was the path listed for upload.

this is from the documents here: https://docs.google.com/document/d/1…q6-Ix3Eyzs/pub

  1. Go to uploader/ folder, open Settings.ini and fill in the values, for example:

GameDirectory=D:\MyGame\WindowsNoEditor your packaged game folder (no trailing slash)

TempFolder=I: emp a folder to store temp files (no trailing slash)

FtpAddress=ftp://123.123.123.123

FtpLogin=john

FtpPassword=12345

FtpPath=/public_html/launcher/ <— MAKE SURE THIS LINE ENDS IN / OTHERWISE IT WILL NOT BE UPLOADED IN THAT FOLDER AND YOU WILL GET A SECURITY FAIL ENDING THE TRANSFER. AKA. THE UNDERLYING CONNECTION WAS CLOSED. AN UNEXPECTED ERROR OCCURRED ON RECEIVE.

Issue #2

this issue may be resolved if it cannot find the files listed from the above transfer. ensure you have 7zip installed on the patcher system and 7zip files associated with it or it won’t unpack the files correctly. also ensure you have the directory structure manually added. the system will not create the folders on upload or deploy they must be preexisting.

Today marks the 1 year anniversary of purchasing the mmo starter kit. We have come along way in that time. considering there are only 2 of us working on this project im feeling pretty good about our progress. Here is a short video showing some of our project. https://youtu.be/v7yEbf-Eju4

Good News! I have the updated project and have a few issues:

  1. The Documentation mentions adding the address for the PHP files. (Done)

  2. Within the Instance, which isn’t exactly where the documentation mentions there is also a field for the Server Address(?) This confuses me.

  3. The database doesn’t seem to be updated when I run the start without attempting to launch from the Editor which I know is not the process. What might I be doing incorrectly here?

These red guys (bad guys) seem to instantly attack me and I am not able to fight back except to run far away from these guys! Maybe I am missing something else also?

Any insights would be helpful.

I have made some progress. I am still not sure what isn’t working, although I did defeat a couple of bandits and a third killed me! So, I seem to be making some headway forward.

@CodeSpartan

​​​​​​​I downloaded the demo also which worked when I registered a character, which doesn’t work in the project using the start level which as I mentioned earlier I know doesn’t work in editor from start to the Desert Rally Race level. Anyway, I am still curious if the the Server Address in the Instance is needed or if that’s option, I seem to recall it’s needed as I had played it. The other problem has gone away appears anyway which was failing the dedicated server check. (Strange!)

@ IFamStudios - if you followed the install guide and setup your db as per the guide. the only things you should need to do are add the hostname/folder/ path in the mmo instance bp (fig. 1) and set the dedicated server under play. The guide states that you use the start map to create a user account and character but don’t try to enter the main map from there. it is not possible in the editor to go from start to desertrallyrace map. however once the user account is created you can enter play in the desertrallyrace map in editor and it will load the first char (char 0).

@CodeSpartan we decided to prepare moving to the newest version. we rolled the base kit to get it setup and test the chat out. this was the first thing we ran into. any thoughts? I’d like to note the chat server is running and the chat works in the clients when logged in. so this is quite confusing.