Download

MMO Starter Kit

That code was battle tested by thousands of hours on a real project, so no. But the chat server is slightly different from the one we used there. What version of the kit are you on?

MMOStarterKit-1.16-for-UE4.21.0

hi CS i wanna ask i wanna use gameplay ability for the ability system…and hwo can i use it and do i need to remove everything in the kit that reference the ability…

and can u redo the launcher as u know the launcher need to have the notepad settings and people can see where i host my php…its not really secure

No clue, I never used Epic’s ability system.

Uploaded the 4.22 version of the kit.

All files have been renamed and moved around to follow Allar’s styleguide. The structure now makes much more sense. I’m going to update the documentation to reflect the changes some time today.

Also some warnings have been added in case you hit “play” in editor without checking the “dedicated server” button or if you don’t set up your database urls.

what’s new for 4.22

“That code was battle tested by thousands of hours on a real project, so no. But the chat server is slightly different from the one we used there. What version of the kit are you on?”

MMOStarterKit-1.16-for-UE4.21.0

Have you modified the sources of the chat server at all?

Could you try this: open the solution in visual studio, build a “Debug” version and run it. See if the problem is reproducible on a debug build.

I had some minor warnings pop up on the demo server occasionally, but right now I decided to investigate them and I’m running the debug build. And for some reason, nothing happens.

“Have you modified the sources of the chat server at all?” no

In 192.168.1.0 network segment is likely to be good

Hey, the reasons for the error may be various. But I have to check some useful solutions:
1.Re-connect your USB device directly to your computer
2. Run the Hardware and Devices troubleshooter
3.Uninstall all your USB controller drivers
4.Update your USB device and motherboard chipset drivers
5.Disable the USB selective suspend feature
6.Adjust your system settings
Or in another way, you may just check the USB device from the Disk Management: Press Win Logo key + R and then type: Diskmgmt.msc to see if your device is there. If it is there, it is easy to be fixed. For more help, just come to this website:7 Solutions to Fix USB Device Malfunctioned & Not Recognized Error

will u add more features like skill tree,revamp or improve the launcher(because the settings.ini show the webhosting)

Has anyone had any success creating a VR MMORPG (or even a small multiplayer like a scaled down WoW in VR) with this kit?

Hello,

I just bough the kit for UE4.22 and I am getting what seems to be BP errors when I open the start map. I got an error on one occasion on the main map, but it seemed like nonsense to me, talking about a cylinder that needed to be movable when there is no such object in the project.
I compiled everything under VS with no errors or warnings.

Here is the message log.

Looks like you’re playing the StartMap with “dedicated server” enabled. Just uncheck it whenever you want to test the StartMap. The StartMap is a particular case, because you don’t want to start a server with this map for obvious reasons.

I’ll implement a warning about that in the next version, if a developer launches it that way.

Thank You very much, that was indeed the problem. I would also like to catch your attention on something that I have been trying out and that is renaming the project, I have tried it several times without success following this guide : https://answers.unrealengine.com/que…c-project.html

And so far, it looks like there is still one area we still need to rename, but I don’t understand what it is. I have tried many times with and without deleting the saved and intermediary folders but to no avail.

HI Allure…

It has been some time since I renamed my kit…

My notes say:

"Used this You_tube to rename Cleanthird to ClawsandPaws: https://www.youtube.com/watch?v=cmK-A8Dh_Ms

Fixed three days of shyte and heart ache trying to follow the unreal article.

After rename… compiled game and C&P was born."

If memory serves correct, I still had to use search and like they show in the youtube video, and rename a couple things the video didn’t show. then recompile…

Hope this helps get you on the right track.

Oh, and Congratz on buying the kit, and welcome to the club. I look forward to seeing screenies if you care to share your progress.

Brilliant, Thank You so much !!!
But it was all in vain lol I don’t know what happened but this time it worked, somehow…

Thank You for such a warm welcome, it’s supercalifragilisticexpialidociously encouraging ! I’m pursuing game making as a simple hobby for now and it’s not always easy getting the help I need, so thanks a bunch, it means a lot !

EDIT : Thanks for sharing, that tutorial end up being a lot more thorough than the one I followed on the forum. Thank You Very Much.

Can I hook the database/registration up to a Debian9 VPS? I want this package only for the registration/login system and want to set it up on a remote linux server if possible. I have a LAMP stack already installed with phpmyadmin working and db’s setup/ready to go.

I don’t know why not, but then I’m not deeply familiar with configuring webservers.