Download

MMO Starter Kit

Launcher engine is very limited in what it can build. You need github engine. I know for a fact that it can’t build server target. I never tried building client target, but it looks like it can’t do it either.

Yes, the Unreal front end is AWESOME… but, you have to remember to compile that also, as it didn’t seem to compile when I compiled the engine.

Also, don’t forget to change the build type in shipping so YOUR .ico is used for your .exe instead of the default unreal one.
Plz see here for more info.

Peace

Hello, I’m new to the unreal engine and the MMO starter kit. I have changed the max walk speed value to 160 and Using blueprints, I tried changing the movement in the MMOPlayerCharacter blueprint to include the ability to “Toggle” between walk and run using a “Keypress” from the keyboard. I am simply “listening” for a keypress and when the keypress is sensed it toggles a flipflop which changes the Max Walk Speed value to 600 for run, or 160 for walk. It appears to be working, meaning it is changing the value as expected, but my character seems to be “Fighting” the speed change and I’m suspecting it is caused by the server over riding the change in this value. If I manually set the Max Walk Speed at 160, my character walks fine in the PIE mode, or if I change the value to 600 my character “Runs” just fine in PIE mode, but if I set the value to either 160 or 600, then allow my keypress to change the value, the character appears to “Jitter”, or “Fight” the change while in PIE mode. How can I fix this please?

The speed needs to be the same on server and on client.
Best way to do it:
1- Call a Server event from client.
2- In this event on server, call a Multicast event.
3- In that multicast event, change the speed, so it happens on both client and server. Multicast events can only be called from server. They’re broadcasted to clients, and they’re executed on server as well.

Server/Multicast is what you set in the event properties:

(make sure to always check the “reliable” box whenever you make server/multicast events)

Not yet sure if this is the best way, but it appears to be working for me.
Please note… I used the “R” key to toggle run.
If someone knows of a reason I shouldn’t be doing it this way, I would be grateful if you would reply here and give your feedback.

The steps I did are below in case someone else wants to do the same.

  1. Go to the MMO folder, then Blueprints. Double click on the MMOPlayerCharacter to open it’s blueprint.

  2. Create a new Boolean variable and name it “IsRunning”, then pull down the replication box and choose “Replicated”.

  3. Create a new Float variable and name it “WalkSpeed”. Again, pull down the replication box and choose “Replicated”.

  4. Create a new function and name it “TogRunWalk”. Add 3 separate inputs/types in this function:
    IsRunning - Boolean
    WalkSpeed - Float
    OurCharMove - Character Movement Component

I then “Wired” the function up like the 1st pic shows.

  1. In the event graph, I did as picture 2 shows.

Notice, I didn’t use multicast, but instead I created a custom event named “TogRunWalkClient” which has 3 inputs and is replicated on Owning Client and is reliable. This event was made to call the “TogRunWalk” custom function we made earlier.
I then made a 2nd custom event named “TogRunWalkSvr” and added the same 3 inputs and is replicated reliably only on the server. This event was also made to call the “TogRunWalk” custom function we made earlier.
Then simply wired it up the rest as shown.

Ported to and tested with 4.21.0
No special steps required if you’re porting yourself. Just turn off runtime physics and vehile physics plugins (not sure which one is causing problems for the engine when packaged, but either way it’s an engine issue and will probably be resolved after a few engine hotfixes).
Fixed a bug that didn’t deserialize group updates properly.
Changed LOD settings on a building in the demo map.

Hello CodeSpartan, great work on this kit, i really like it. I have a stupid question! If i set the maximum player to 100 per session. How that’s work to have 10 sessions of 100 players? Do i need 10 VPS?

It’s a bit of an advanced subject, but short answer:

  • each software server can represent a certain area
  • a hardware server can host multiple software servers (because it’s got many cores and can handle it)
  • when you reach your maximum amount of players in an area, you can start sharding the area, although that functionality isn’t part of the MMOKit

Where to change password, use WEB server?

You can download any sqlite browser utility, such as this one: https://sqlitebrowser.org/
Open “users.db” and delete this user:

Open deployer/index.php and change line 41 from private $allowRegistration = FALSE; to TRUE;

Go on the website, you now will have a “register” button. Register your new admin, then revert $allowRegistration back to FALSE.

GameUploader ,Cannot upload,why? FlashFXP can upload

Launcher ,Cannot download

I think it’s simply due to the fact that the uploader is configured to work with linux and you’re trying to upload it into a local windows directory, which results in paths that windows doesn’t understand. (the path separator is different on different systems and I’m not sure it’s even possible to retrieve the OS from the ftp protocol, so I simply assumed that it’d always be linux)

FTP space is empty, why?

Packaging

project launcher,UnrealFrontend, and Package Project,What’s the difference?

Here’s where the error occurs:

So what fails is $zip->open, the error code stands for **ZIPARCHIVE::ER_NOZIP. **So the system doesn’t think it’s a zip archive. Can you try opening it on your local machine to make sure the file isn’t corrupt?

Since I can’t reproduce the error, I can only guess at different solutions, but if it’s on the server side, my guess would be that you’re on a different php version. My scripts required 5.5, and it’s likelier to catch unexpected behavior the further you get away from 5.5. What version are you on?

The difference is that if you cook in UE4, you won’t get server target. If can always cook the server.exe in visual studio, but it’s a more complicated way to do things. Older documentation used to reference this method, but there are no benefits to it.

Please Help Project Not Opening error (

What’s the error?

Current PHP version: 5.5.30

the big file isn’t corrupt,But it did not succeed.

Small files is right

Do you have another hosting you could try it on?

yes,have another hosting could try it on