Download

MMO Starter Kit

has anyone got open level to work yet, if so what have you done? the part in the documentation is very vague

You mean to transfer between Servers processes?

What’s the last working version of Unreal Engine that is working correctly or does it not work like that ? Haha what I mean is can I just get an older version of Unreal and then continue to use that older version to create the game that I would be working on ?

From what I can see you only need to do three things for the Kit to work with 4.14

  1. Comment out or delete the last two public override parts parts dealing with MonolithicOnly in CleanThirdPersonServer.Target.cs in Source
  2. Change CommandChatWho in MMOCharacter to use Get Num Player function instead of the old way of grabbing the value directly
  3. Fix the cast to MMOPlayerCharacter for Try to Loot in MMOPlayerController / Right Click

Seems to play just fine after those changes.

how do i change the picture on the launcher to m own?
Cheers

Extract Source.zip then open launcher01.sln

IN launcher / assests / you will find background-image.bmp

I believe that is the pic you need to replace.

I follow the documentation exactly along with some of Nemo’s videos and in the end I still get a “Wrong client version” error when trying to enter the world from the launcher. The only way it works is if I set the server.exe to run in “-local” along with the client also in -local. Trying to figure out where the mismatch is.

Anyone seen CS…

<crosses fingers and hopes.>

Nak1411,

I had the same error… I hooked up with CS in Slype and he looked over my setup. And scratched his head. I then took a clean copy of the kit, and ran it step by step, including setting up the PHP files again from scratch. Oh, and I set up a new database dbstructure.sql (I deleted my one first then redid it.) And for what ever reason it all worked. A few months later, the ip changed on my server and I believe I got the same error until I updated the IP in mmogetserver.php Not sure on that one though, that might be another issue I had. I can’t remember.

So, my advice would be to backup your PHP files… build a new Database with differernt name… go thru the setup with a non modified kit and see if you can get it to work. If so, then you can T-shoot your first kit from there.

Good luck bud.

The way I get it to work is by putting “-local” in the client exe path. Then I can enter the world, chat server and server log shows me connecting, database updates correctly and everything is fine. I have a feeling this isn’t the correct way to do it, having to put “-local”. I have narrowed it down to that so far. I am not very good with networking stuff, but as soon as I remove -local, I assume it is looking for another IP rather than ‘localhost’ ? Which would explain why I cant enter through the launcher because the launcher is using the non-local exe.

I hope CodeSpartan gets a chance to port it over to latest version, I want to dive back into videos soon as work let’s up right after Christmas.

Nemo

just i thought did you update json in the kit when you changed ip?

Did you put your server IP in mmogetserver.php ?

I redid everything on a non-modified kit step by step. I get the same wrong client version error no matter what I do. I am out of ideas. It only works on local. Disabling firewall doesn’t help. I was able to ping the server successfully so that is not an issue. I even upgraded to a better host for ftp and database. Reloaded new phps and everything to no avail.

Only thing I can maybe see is maybe I am building things in the wrong order??

  1. I make changes in the editor.
  2. Then in VS I build the Development
  3. Build Development Server
  4. Package in editor using a full rebuild.
  5. Then just copy the built server exe over to the packaged client exe.

Is that wrong? Correct me if I am wrong but it seems like maybe doing a full rebuild during packaging would screw it up? Wouldn’t that create a discrepancy between the packaged client exe and the server exe built in VS?

I might just wait for a 4.14 update and see if that changes anything. Otherwise I have no clue.

Hey spartan, I sent you a quick pm on skype. Loving the work you’ve put into this, for sure, very quick to get it mostly setup and already integrated for my current project. I am… however… experiencing a little technical difficulties as well. I’ve gotten most of the problems fixed, like the launcher upload issue, mysql login works on client, ect. But no matter how I execute the server/client (with -local or -port=xxx or anything/nothing) everytime the client hits the button to enter world it brings up a load screen for a few seconds then an error box “fatal error!” and client crashes.

I noticed two things in the server logs, one was a reference to an invalid userid to the login request (but I’m pretty sure that’s epics handshake) and the other is a warning about GetSimulationTimeStep() - Max iterations 8 hit while remaining time 1244.008423 . . . Pretty sure that ones nothing as well because it references “falling” which is what the character does on the start of the server map.

So with that said, i think the crux of my problem is truly in port 7777. I host the server binary on a server rack sitting next to me and both PC’s are in fact behind the firewall. The server is setup with a static internal IP and all of the other relevant ports have been forwarded as well (it does look like everything is working great with mysql, apache, ftp, launcher, ect…). I have let the binaries through the firewall, all of the needed ports and everything in between that I can think of and port checkers still show that 7777 is unavailable. Been on this particular problem for a full day and a half now and I think I’m out of options! >.< God knows as soon as I post this though, it’ll start working though, watch… For real though, if you’re able to help you can hit me back on skype. I know you’re probably pretty tied up this holiday season though! :slight_smile:

Hmm why dont you try putting the IP on DMZ? and maybe turning off firewall… I dont think this would matter but you could also try open ip : port from the client and see what’s up… On the server (besides the -port=Port, -log) you could also add “MapName” (your map name, without the " ") to specifically load that map.

yep, tried all of these steps, DMZ on and off, router set to my DDNS on and off, UPNP on and off, firewall has exceptions and rules to allow ports and programs through (all of them including apache, server, ect) and turned on and off. I’ve opened the map name, the ip, the ip with port, tried running server locally on my main machine that I build from before I deploy to the server (-local tag) and no matter what I do it is always the same case. The initial map loads fine, lets me login to the mysql database fine (tables altered fine if i register, create or delete characters, ect) but as soon as I enter world the loading screen pops up, plays for a few seconds then “fatal error.” I get the fatal error every which way I try to open my server map.

It’s also worth mentioning as well that when I run netstat -ab -p UDP port 7777 is taken by:
0.0.0.0:svchost.exe

I have no “svchost.exe” application in task manager to kill per say… however I have a few service host applications with sub applications all being run from this application. “Service Host: Network Service(5)” for example. Not sure if I should kill these and try again or if that’s a major windows function for windows server 2012 R2. I guess a bit later when I get frustrated enough I might try it lol.

EDIT:
UPDATE:

So after working with it a bunch more tonight I found a few silly mistakes I made, and also came to the conclusion the NAT router wasn’t necessarily “helping” my situation so I decided to port it over to a VPS. I got everything setup as per usual, mysql, apache, forwarded ports, ect, but I’m still crashing on entering the world.

I double checked and have rebuilt the client and server multiple times to make sure the maps were being cooked, and it is definitely logging that the map is there in the server log. This time I was able to `open “mapname” from within the client and it loaded the map!!! no UI or anything of course because it bypassed the login, but finally some headway.

This leads me to think that somewhere in the chain something isn’t going right when it tries to actually start loading the map on the client. (I still get the simulation timestep error in log as well as it pretty much looks exactly the same, no change.) At this point I’m not sure what else it could be.

I am running 4.13 as well just btw, figured I’d make mention of that.

I’m using the kit in 4.14 just fine…

take a screenshot of your mmogetserver.php and of mmoinstance inside the kit
also what is your php server version?

Current PHP version: 5.6.28
running xampp for apache and mysql

if you’re referring to if they are identical then yes and no. I’m running a no-ip dns.

“Hostname” in mmoinstance is set to http://dnsurl/
mmogetserver.php is referencing the external ip of the vps server. Do both of these need to reference the external ip? Didn’t really think that mattered as the connection is being registered on the server (showing that its doing something) so I assumed no ports were holding it back and the dns did its job and routed the request.

Also, i do have the .dll for the php zip, that doesn’t really matter right now though I think because I’m not even on the launcher stage…