MMO Starter Kit

there pvp system ?

Will the extraction of resources, Kraft?

I could not go to the test server

I’m having install issues. I’m using Windows 7 with Visual Studio 2015 installed.

I have downloaded UE4 version 4.13 from release branch of github and installed it at C:/UnrealEngine-4.13 and built it the source version.

I have MMOStarterKit-1.7 at C:/MyGame/MMOStarterKit-1.7

I have tried right clicking on the CleanThirdPerson project file and “Generating Visual Studio project files” but I keep getting this error:

Building UnrealBuildTool in C:/UnrealEngine-4.13…
Couldn’t find C:/Program Files (x86)/Microsoft Visual Studio 14.0/Common7/Tools/…/…/VC/bin/x86_amd64/vcvarsx86_amd64.bat; skipping.

Am I doing something wrong? I have searched for the solution to this error and not finding anything that makes this work.

I’d try looking for the vcvarsx86_amd64.bat file in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\ . If it’s indeed there, try opening “%VS140COMNTOOLS%…/…/VC/bin/x86_amd64” in windows explorer. It should take you to the folder with that vcvarsx86_amd64.bat file. If it doesn’t, make sure that Windows has an environment variable called “VS140COMNTOOLS” and that it’s set to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\

Open the blueprint, select the mesh component and disable “Receives Decals” under “Rendering” category, this should do it.

It seems to be missing. Is there a specific version of Visual Studio I need to install on a 64-bit Windows 7 OS to make this work?

I’ve never used Visual Studio I’m a PHP developer so I’ve not run into issues like this before.

I installed Visual Studio Community 2015 and all seems to work. After the install I had to go back and add a couple chk marks in the repair / add section… but… clear sailing other than that.



Never ran into this issue either. I’d recommend you reinstall Visual Studio, the problem seems to be there.

Hello everyone!

I’m having an issue and I’ve tried to look it up on my own but I can’t get a solid answer going through Google.

  1. I’ve changed my mmocharacter attackfx and it works for 1 enemy. I tried to duplicate the attackfx within the same blueprint and it doesn’t work. I also tried to duplicate the mmocharacter BP and try again with no luck. Is their an easy way to have multiple attackfx for multiple enemies, and is it really that simple of an answer I’m just a silly soul lol.

  2. I have my enemy characters set up and they work well enough aside from that attack animations. But, when my newly created character dies. If I stand still, I can still *sometimes take damage from the AI after it has been killed. As well, the pawn/dead mesh move around the map after death. Either flying into the sky or just rolling around the map.

3rd. My characters I’ve added are extremely jittery, movement is really odd and they are constantly hopping around like bunnies on crack.

I apologize if these questions can be answered easily, I may not have specified my questions well enough when searching.

I installed, then had to do uninstall -> repair then select all the 40gb of content to be installed for VS 15 to work.

Edit: didn’t read the post properly.

i ran into this problem as well, make sure the new animations you are using are set to Root Motion


Enabling root motion just made them sink into the ground when they entered combat mode and in combat idle lol.

with root motion enabled try changing the “Root Motion Lock” to “Anim First Frame” or “Zero”

Sadly, neither have worked. I’ll keep fiddling with the BP’S. I appreciate the help that’s been given.

Edit: I got it working. I copy/pasted attackfx in ai character event graph.

However I still have the issue of the character drifting around the map after death animation and the prior ones from previous post.

“Sequence contains no matching element”

I keep getting this message with my uploader and its not uploading, does anyone know what it means?


So I just downloaded you client and was Massively Impressed!! Great Job!!

I have a few questions about the kit:

When I use the mouse scroll wheel it zooms to her panties. Though this made me smile, I was wondering if there are plans to make it pop into a first person camera view when fully zoomed in?

I am assuming that Multiple player meshes can be used for the player. Is this set up already in the kit?

At some point I ran past the bandits and found a huge bridge. There is a section that doesn’t have colliders and I fell under the bridge mesh. Is there a Hotkey to Teleport in case the player gets stuck?

Also is there a Teleporter system to teleport to the nearest one if the player dies? (Handy on large terrains)

Since I have dealt with coding Purchasing Items in games on Unity and know what a pain it can be, Are there any plans to incorporate Playfab or Gamesparks for this? Allowing them to handle the cash stuff while the game is run on my own server.

And Lastly, can I set a Player Max Limit that blocks new Log-Ins to prevent server overload?

Question for anyone, I Am looking for the logic when the server starts up. I am looking to implement place-able world objects that need to be loaded at server start. Does anyone know where the boot up server process is handled? where I might be able to call an event to load items on the map?

I am having an issue with guild and party commands, all the other chat functions i can chat and whisper other players. My problem is /gcreate <name> is having no response in the chat field. also party invite ques the party invite text to the other player but no party is created after and party chat will not work. has anyone had an issue like this?

have you replaced the db files with the new db files?


In the text bar will teleport you to the player start location

It its a complete clean install of the 4.13 version. I followed all the steps from

I am not running Soruce tho maybe that has something to do with it?

I missed step. 7 in the doc
“Open hostname.ini file located in Chat\ folder with Notepad or other text editor and place the same url as in p.6 there”

Hi, I like the look of this kit and tried to download the test client to have a look, however I’m having some issues getting it to run if anyone can help.
I tried to run the client on my windows 10 rig, the launcher works fine but the downloaded .exe is completely unresponsive, considering an OS issue I then attempted to run it on my windows 7 laptop, I then initially had an issue with missing direct X dll’s which was an easy fix, but it now seems that there is a physx dll missing that I can’t fix.
The dll in question is called “Physx3CommonPROFILE_x64.dll”, the laptop does have a nvidia GPU chip inside it “Geoforce gtx 850m” and an i5 Intel processor, so I know the laptop is capable on running an unreal project build, iv tried to install physx features manually from download and automatically using Geoforce experience which I believe does install physx apart of its drivers.
Any help is apreciated so I can give this a test :slight_smile: