Mesh Shadows Problem

Hey all. I’m having some troubles on shadows. I can explain to clearly with images;

How can I fix these problem?

-make sure that you build your light with high or production settings so that you get the final light quality
-which error message do you get? click on the “show message log” button
-increase the lightmap resolution of the bed mesh
-add a lightmass importance volume :slight_smile:

I’ve changed Mobility setting “Static” to “Movable” and shadows are showing right now lol, is this will be a problem?

Then your light will be dynamic, so your performance wont be so good anymore :slight_smile: