Max layers per landscape component 4.26


I’ve been bothered by a question ever since I transfered my project containing a perfectly working landscape with 19 layers (>50 textures in total) from 4.24 to 4.26 and suddenly the material is looking as if it’s a default one. At first I assumed the material got corrupted, however further investigation led to the only one conclusion: it works perfectly if the number of used layers per component is less than 5.

Please note, that all textures have samplers set as WRAP, which helped to get the required result in 4.24. Also the button “Max painter layers per component” seemingly does nothing, whether it’s 0 or 20.

I would be very grateful and happy if anyone can help me resolve the issue.

There’s a total number of samples allowed. Should be 128.
In sm3 its 16. So make sure the material is sm5.

Aside form that, Maybe the value was changed in the later version, but its derived from a DirectX limitation.

Could also be you need to enable DX12 in your project if it was using that before.

Thanks for a quick response!

Unfortunately it’s about neither enabling nor disabling DX in the project. Also seems like it’s not about SM5. The only apparent difference in the context of the issue between 4.24 and 4.26 I found so far is sudden going up from “Num shaders added: 68” to “Num shaders added: 126”. I also tried reducing the number of samplers but to no avail, there is no difference when it comes to opening the material in U4 4.26.