Mavericks - Lag to 1FPS with no graphics updates available

I am running Unreal Engine 4.4.3 on an Early 2011 13-inch running OS X Mavericks 10.9.5 (latest). There are no graphics driver updates available in App Store (which was suggested for previous similar questions).

After opening a project in Unreal Engine, I try to drag viewport editor like driving a car as suggested in tutorial (dragging up & down, left and right to turn). However, editor lags to about 1 frame per second when I try to do this, occasionally getting to point where application stops responding

When I first tried to open up Unreal Engine, it said something to effect of “Your graphics quality is low. We are downgrading you to 10FPS automatically”. Could this be part of issue?

Not sure if this is related, but when I tried building Unreal Engine from source, Xcode was “building external script” for about 3 hours before I quit and downloaded normal GUI version.

I will try and download 4.5 beta and see if that helps resolve issue.

Are there any sort of logs I could generate and attach?

Hi iggyvolz,

Please provide more information about your Mac’s specs. You can find this in Apple menu >About This Mac>More Info> Add information from this window (serial # not necessary).

We also need following information from the “System Report:”
Apple menu >About This Mac>More Info> System Report>Hardware (All information listed in the “Hardware Overview.”) You can cut and paste this information or provide screen shots, whichever is more convenient.


Coming right up! Slow wi-fi and I’m multitasking, so bear with me.

About this mac

13-Inch, Early 2011

Processor 2.3 GHz Intel Core i5

Memory 4 GB 1333 MHz DDR3

Graphics Intel HD Graphics 3000 384 MB

Serial Number hidden

Software OS X 10.9.5 (13F34)

Hardware Overview

Model Name

Model Identifier MacBookPro8,1

Processor Name Intel Core i5

Processor Speed 2.3 GHz

Number of Processors 1

Total Number of Cores 2

L2 Cache (per Core) 256 KB

L3 Cache 3 MB

Memory 4 GB

Boot ROM Version MBP81.0047.B27

SMC Version (system) 1.68f99

Serial Number (system) hidden

Hardware UUID 5D849E64-8538-56B1-AB58-AC18BC8577C2

Sudden Motion Sensor State Enabled

Hi iggyvols,

Your machine’s graphics card is HD Graphics 3000 which runs Open GL Version 3.3. UE4 is designed to run with Open GL 4.1. While you should still be able to run engine, it will not run as well. I will contact developers to see if there is anything you can do to increase performance and I’ll let you know.


Thank you very much! I found another Mac which can run HD Graphics 4000 (I’m assuming that’s Open GL 4.x), so I can use that if it is impossible to use mac I am on.

It’s amazing to see developers who actually support software they put out… you guys are awesome.

Hey iggyvolz,

Glad you have another machine to work with! Yes, HD Graphics 4000 uses Open GL 4.1, so hopefully you won’t have this issue on that machine. If you run into more trouble with that machine, please let us know. Thanks!

Intel HD 3000 has a severe OpenGL driver issue under Mac OS X that makes UE4 extremely slow on that GPU, that’s why you were seeing 1 FPS. Intel HD 4000 will be much faster, but for best UE4 experience you really need a high-end Nvidia or AMD GPU like BTO 27" iMac or 2013 .