Material wont apply in blender mesh .fbx

What happens when you apply the material through the details panel of the mesh?

Well what I did is I put a high poly monkey(suzanne) in ue4 scene. I tried to drag and drop a material from the the starter content to suzanne and the material wont apply.

in this one I tried using a cobble stone material

Same thing happnes

Can it be a UV scale problem? Can you check out the UV’s in static mesh editor please? Maybe it is way too large or way too small so the textures aren’t tiling in proper scale.

I’m not sure but that mesh doesnt have any material on it when I import it to ue4. Ive tried to import a mesh that was UV unwrapped and has materials on it. And all other material works perfectly fine. I’m thinking you need to UV unwrap a mesh before importing to ue4.

You need to UV Unwrap your Mesh in Blender before importing it into Unreal Engine.

Go into blender, unpack into UVs and export it as an fbx / obj.
Go into UE4, delete your old suzanne mesh completly, then import it again.
Now try to apply your material.

See if that worked.

Yes, the mesh needs to be properly UV mapped if you are going to use textures in it’s material and/or use it as a static mesh with static lighting(for lightmaps.)