Material Ray Tracing Shadows

I noticwed that all my materials have the “cast Ray Trace Shadows” Option checked off.

Does this mean that Ray tracing is enabled?
Should I uncheck this on all my materials to save performance?
How do i Disable RT?

I am not planning on using RT in my current game project. I am just trying to squeeze as much performance I can out of this game.