Download

Material Error w/ Landscape Visibility and Grass Ouput Nodes

Problem
The Grass output becomes super densely populated without regard to its settings when I use the Landscape visibility node on the Visibility material.
Example
landscapeerror.jpg This only occurs on the Landscape component that has visibility drawn on it using the Sculpting > Visibility Tool.

Description
Here are the landscape material settings.

These are the settings of the base Landscape Material
landscapematerial1settings.png
These are the settings of the Visibility Landscape Material
landscapematerialvisibilitysettings.png

Now, I copied the base landscape material verbatim and renamed it and then added the Landscape Visibility Node in the material editor to the opacity mask. It works fine, except for the grass output gets messed up in that component I removed visibility.

I’ve tried different approaches to this problem, but nothing seems to work.

Any thoughts?