Material BlendMode affects decals

If you want a material in the Deferred Decal domain to have transparency you have to change not only the Decal Blend Mode but also the Blend Mode. This would be fine (albeit a bit confusing) but the Blend Mode drop down is grayed out when it’s in the decal domain, so you have to switch to Surface, change the blend mode, then change it back.

86353-blendmode.png

I don’t know if the regular blend mode just shouldn’t affect decals or if that drop down should work all the time, but either way it seems like a bug.

Hey kgamble,

This is not a bug, but the intended functionality. You can tell because as soon as you switch to the ‘Deferred Decal’ Material Domain, certain inputs for the material are disabled. The Decal Blend mode is specific for decals, and this was done in part, so users do not use incorrect blend modes that do not render with decals in the engine.

You can also see that the ‘Opacity’ input in still exposed, which means the Decal Blend Mode is setting the material inputs correctly.

Cheers,

Andrew Hurley

I wasn’t sure if it was supposed to work this way or not. It’s just confusing because the drop down for the blend mode is grayed out if your material domain is deferred decal so if it’s set to opaque you have to change the domain, change the blend mode, then change the domain back.

In other words, it seems like what the Blend Mode is set to shouldn’t have an effect because I’m not able to change it unless I first change a different setting. This confused me for a bit yesterday when I made a new decal material and it was rendering opaque even though I had connected the texture’s alpha pin to the opacity output pin.