Download

Making light not TOO bright

Hi guys!

In my game, you carry around a little staff that lights your path. The problem is that while it casts light nicely on the ground, it is very much too bright on the staff itself! See pic for better understanding:

Screenshot_18.png

The only way I can think of fixing this is somehow clamping the max brightness on the mesh itself for dynamic lights? I’m not quite sure…

Thanks!

EDIT: Yeah major typo in title, cringes every time I look at it, but they don’t let us change it for some reason. If someone has that power, please turn “TO” to “TOO”… derrrrr

Try turning off the Inverse Squared Falloff option under the advanced lighting options. After doing that, you’ll have to drastically reduce the intensity of your light, but it will be more even over the range of it’s effect.

You could also paint problematic parts with darker albedo.