Major juddering using Oculus DK2

Hi, I’m recent to Unreal and I’m having some problems with the VR.

I’m making a ArchViz project, with lowpoly geometries and every lights and objects static so that it won’t weight that much on the machine, and it runs great in PIE (play in editor) but I can’t get the scene to 150 fps and I’ve cleaned almost the entire scene, but the best I get is 120.

I’ve tried the scene with oculus and the juddering is ridiculous. I also packaged it for windows and the problem remained. I’m currently using Engine 4.10.4.

Any help or input would be most welcome.

Thank u

What is your FPS and more importantly the output of stat unit when you have it running in the DK2?

What command should I run in the console to see that. Actually I have already solved the problem at the expense of screen percentage, but if I could up the SP without losing performance that would be great.

Also the FPS i´m running is around 75!

Just curious, what hmd sp value are using to run without judder? I’m optimizing for VR using a DK2 as well…

If your at 75 you shouldnt have judder unless you keep dipping below 75.

stat unit will give you info on your frame time to determine where the issue is. If you’re using NVidia GPU, make sure you download the latest driver (released on 3/8). I was having some inconsistent DK2 behavior with the driver that released on 3/1. Adjusting the SP to get your frame rate to improve suggests your bottleneck is on GPU. Read up on the GPU profiler tool in the UE4 documentation and take advantage of that, in addition to the CPU profiler.

A common cause of rift judder is the post processing. As a test you could go to your project settings and turn them all off, then see if you get your frame rate back.
Shadow casting lights seem expensive so try without any of those although you said most of your lighting was baked.

Do you get any errors with regards to Dynamic Shadows (check error console) when you build lighting…

I have had this a few times…(turn the Dynamic Shadows off) and fixes it…

Just giving you something else to check…