Download

Major Judder - DK2 Issues

Hey everyone!

So I’ve been working on a demo, and we are using the DK2 to visualize it. I have been getting REALLY bad judder for a while now, but mostly when turning your head in the rift. I thought it may be my level, so I created a new FPS project with no demo content, opened it up, ran the stand alone, and hit Alt-Enter, and I’m still getting REALLY bad judder. I’ve seen that others have been experiencing this too, but I haven’t seen any solution. Here is what my system setup is like:

  • Toshiba Qosmio Laptop
  • 32 GB RAM
  • NVidia Geforce GTX 770M 3GB VRAM
  • Intel Core i7 4700MQ @ 2.40GHz
  • Unreal Engine 4.5.1
  • DK2
  • Oculus Runtime/SDK v 0.4.3
  • Oculus Firmware 2.12
  • Oculus plugged directly into HDMI, and 2 USB 3.0 ports for tracing camera
  • Realtime turned off in editor, and viewport set to wireframe
  • Standalone viewport on laptop has no judder, just inside of Rift

With this setup, I’m at a loss as to why when I open the simple FPS start level, I’m getting 24-30 fps and VERY bad juddering when turning my head. If I hold my head still, everything runs really smooth. Looking around it’s so laggy it’s unusable. If anyone has suggestions, it would be great help! I’ll see if I can upload a video of the issue to show the problem. Thanks!

Most common causes:

  • You leave the editor open when you start the game (taking off realtime does help, but its still consuming some cycles)
  • You simply have too much in your scene
  • You don’t turn off framerate smoothing which is capping your fps at 60 (what does “stat fps” in console report?)
  • You place the camera way out from the center, causing fp precision problems

And since you’re using a laptop you might be running into the Optimus issue of capping your fps at 60.

There’s an option somewhere in the preferences to the tune of ‘use low CPU when in background’ - if its not already ticked on, try that. Fixed 99.9% of the judder issues for us.

remove 0.4.3 and install 0.4.2

Thanks, SiggiG. Closing the editor doesn’t help. It judders just as bad in a blank level. Framerate smoothing is off (stat fps shows 18-24 fps). The camera is located at (-619, 1544, 424) in world space, and centered on the player.

Crow87 - I looked all over the Project Settings tab and can’t find anything like that. Am I looking in the wrong place?

knack - 0.4.2 was just as bad. There was no change between them.

I also have made sure that my power settings are set to “High Performance” - no luck. I’m also noticing that when I play the Tuscany Demo off the Oculus website, I’m getting the same problem, and that is not UE4. That leads me to believe that it is something outside of Unreal that is the problem.

hey man,

It’s gonna be impossible for you to get no judder with only 18-24fps with the rift on. you need something like 60fps+ to get a smooth experience.
try reducing your supersampling and tightening the visible area, that should help getting your FPS up a bit.

If you are getting 18-24 fps even on a basic scene, I’d say there is a high chance your laptop isn’t using your integrated GPU and switching to the Intel chipset one for some reason.

You should be getting a decent fps with a 770M, but you might hit the dreaded “laptop 60 fps” wall…

I used the Nvidia Optimus tools to see if the integrated card is running it. Nope, it says the NVidia card is running it. I even specifically used the Nvidia Control panel to make sure that anytime unrealeditor.exe is run, it forces the NVidia card.

At this point, all I can think is that it’s because I’m using a 770M (mobile chipset) rather than a full desktop card. Does anyone know of a way to make sure that the HDMI out port is being driven by the NVidia GPU and not the integrated Intel GPU?

In 0.4.2 disable aero, and mirror.
In 0.4.3 enabled aero.

if that not help try in a non-mobile chipset.