MAJOR 4.11 bug on android

I don’t even understand how this is happening on 4.11. When I opened my android project on 4.11 first thing I did is package my app and upload it to the play store alpha testing to see if it would work and of course I was 100% right. When I played my game it opened the defult main menu and then when I click play to go to the next level it doesn’t register or find any level and opens up again the defult main menu level. I thought something was wrong so I went back to the same project but for 4.10 and packaged and uploaded it. Once i played it, it worked like a charm. And keep in mind the project on 4.10 is the SAME EXACT copy for 4.11. I didn’t mess with or change anything on 4.11 project. Its the same working one as the 4.10 one. So somethings wrong with 4.11 and I’m asking why this is happening.

what version of 4.11 are you using? there are some pretty important fixes in the current source version at the moment. I still suspect there are more critical fixes needed as well

Hello @Spookey0188,
I had the same issue on 4.10. The reason was that ue4 compiles only default/starter map.
So how I fixed that:

  • Open DefaultEditor.ini file in this path [YourProject]/Config
  • Then add following code


Are you packaging the game or launching it? If you’re just launching it it’s normal to transmit only 1 level - the one the editor is currently on. The old version likely works because you either launched the other levels or packaged for that version at some point

I said in my post I’m packaging the whole game

im using 4.11.1

Sorry I tried what you suggested and unfortunately it doesn’t work. This is what I put


Hi Spookey0188,

I does sounds like your other maps aren’t cooked. The game default map is always cooked.

Did you really name your Maps folder [Content]? If 2d_MainMenu is in your project’s Content, then it should just be +Map=/Game/2nd_MainMenu. If it is in Content/Maps, then it is +Map=/Game/Maps/2nd_MainMenu.

I have encountered this BUG after upgrading from 4.10 to 4.11.You probably just click on the make a copy option when converting to 4.11,right?This will cause large numbers of warnings when you open your project in 4.11.
If in that case,you just try renaming your project folder and then try packaging it again.At least it works for me.(Before renaming the project, the final app is only 150mb+,after doing that,my packaged app size will be the normal 500mb+ size)

I hope this BUG can be fixed in the final build.

This worked thanks