Download

Main Menu and Blank Projects - Unable to Set Default Character on Level Load

Hi everyone,

First time post but I’ve come across something which has caused me to come across a stumbling block and something I’m not sure if is down to something not being instantiated correctly or just something that might even be categorised as a bug… nonetheless here goes…

I’ve been working with a Blank Project template and have wanted to add a main menu into my sequence which of course uses the default pawn class “Character” as usually expected and of course given by example in the official documentation Creating a Main Menu.

While this has always worked for me when creating from a First Person Template, and natively a Third Person to boot, when I’ve gone through the process on a “Blank” template it simply refuses to yield the same result. For clarity, inside a Blank Project I’ve created a new “GameMode” class and assigned usual details such as the intended pawn that I want to use and apply and this GameMode is set under “Maps and Modes” etc.

The problem that I face is that when I want to use my main menu level, which I have called “Iso_Main”, and use the “World Settings” to override the Game Mode from “None” to the name of my game mode and override the “DefaultPawnClass” it simply will not load my character on the level after I use the menu.

I’ve gone through the process several times and unfortunately yield the same result when I attempt it although a “ThirdPerson” or “FirstPerson” template works perfectly fine. Has anyone else experienced this with the “Blank” template at all or am I missing something glaringly obvious? I’ve popped a few screenshots below to show project set up etc.

Maps and Modes

Main Menu Level with the Default Pawn Class changed to “Character”
image

First level set as normal as no override is taking place
image

If anyone has any advice or can point me in the right direction it would be greatly appreciated. I do feel it’s something in the “Blank” template not instantiating from somewhere correctly in the backend but I’m not 100%

Hi all,

A follow up post after some further digging. I’ve noticed some of the Default… ini files do have a few differences between them such as boolean flags being abled for BluePrint editing but nothing of significance that I would think would cause the guide not to function between a Blank Project and one of the sample projects that have already been created in template form.

I’ve tried this both in V4.25 and V4.26, just to contain the project to specific build releases, but will have a look in V4.27 but neither of the two candidate releases have allowed it to work. I’m wondering if anyone else has had the opportunity to test it to see if its just something I’m massively missing. As I said just a “Blank” template which I’ve assigned a new “GameMode”, made a Character (and just given it a mesh for visual aesthetics) and of course a simple menu with a button. Just still a little baffled why it works in the FP and TP samples but not in the Blank. I’m wondering if theres something that’s just not enabled by default in the blank.

Appreciate any responses that anyone may have.