Download

Lost all gameplay movement and cursor control of the pawn

When I play the game from the Editor within the Selected Viewport, all my control over the Pawn has been lost. Keyboard and mouse control do not work. Nor does anything in VR work for rotating your head, etc.

Only if I hit Alt-S when playing and eject from the pawn can I rotate around the screen with the mouse cursor. Clicking Alt-S to re-possess the pawn leaves me stuck and unable to move the pawn/camera.

I started with a default VR template scene and have not done much to modify it. Previously, both the VR and viewport/keyboard/mouse movement worked fine.

I tried making UI widgets but have disabled these completely while trying to solve the issue. If I make and activate a 2d widget for swapping lighting scenarios, with two widget buttons that show up on screen in the viewport, the cursor DOES respond to that during gameplay. But the minute that I click elsewhere in the screen during gameplay to move the pawn/camera, again there is no response, no pawn movement at all.

And oddly enough, this is not limited to one particular project, but several, including those I have not opened in weeks. And yet there is at least one or two other UE projects that work fine gameplaying from the Editor into the viewport using the cursor.

What is wrong?!

Thank you for any help,
Matt

UPDATE: The loss of control has something to do with the VRPawn from the VR Template project. If I create a blank Unreal Studio project, which only has a Player Controller icon on the screen, when playing in the viewport, the cursor works to control movement. If I import and drop the VR feature pack’s VRPawn onto the screen, set the VRPawn to its AutoPossess to Player 0 and try to play again, the cursor does not respond and the player is stuck. If the VRPawn’s AutoPossess is on Default (or not to possess) then gameplay reverts to the Player Controller icon and the mouse cursor works fine.

So what is causing the Pawn to lose any link to the cursor to control movement? This is happening in all my VR-template based projects, so it does not seem to be a particular project’s settings…

UPDATE: Just downloaded UE 4.23. Opened a blank Unreal Studio template and the cursor works. Opened a brand new Blueprint VR template and like above in 4.22, the cursor has no control when testing gameplay movement of the VR Pawn.

Any help please!

Does anyone have any ideas what is wrong? It’s a week later; I opened up UE again and the cursor still has no control with VR pawns in the scene.

Thanks,
Matt

Any help? The lost cursor/ pawn movement issue still exists, even after loading up the 4.23.1 update.