Download

LOD lightmaps

I’m struggling with importing custom LODs into the engine. Specifically - lightmaps for those LODs.
My issue is - after light bake, the engine automatically assigns some lightmap resolution to LODs after 0. I.e. the LOD0 uses the lightmap resolution that I specified in the static mesh settings. And LOD1, LOD2 etc use… whatever the engine thinks they should use.
And this is a major problem, because I have no idea what lightmap resolution does it wants for those LODs, so I can’t adjust proper texel density for them in maya.
If I use “Generate Lightmaps” in ue4 for custom LODs, I run into the same issue.

This is LOD0 on a window.

This is LOD1:

Camera distance is not that big, but lightmap resolution difference is massive.
And this results in LOD pop-ins when moving around the scene:

I couldn’t find any way to control what lightmap resolution each LOD should use inside the UE4.
Weirdly enough, if LODs are generated in-engine, there’s no issue with lighting and all LODs’ lightmaps use the same texel density as the base mesh.
Problem is, for some meshes, like this window, I can’t trust the engine with generating LODs. It screws up the profile too much so it becomes noticeable.

Please, help! I’m pulling my hair out already!

Hey… Open your window mesh in the static mesh editor. In Details you should have a “Lod Picker” section that has a drop down that lists Lod auto and Lod0-X for each of the Lods you’ve imported for this mesh. When you select a specific Lod here, the section below should change to “LodX”. In this section under Build Settings there’s a setting “Min Lightmap Resolution”, you can increase the value (powers of 2 only) here to increase the minimum size of the auto generated lightmap for this lod. In General Settings there’s also a Lightmap Resolution setting…

Hope this helps

ps I also found when I was working on lods I was being far too aggressive on how soon I was trying to bring in the lower lods, if you increase the distance before bringing in the lower lods that also helps a lot… (In Lod Settings disable “Auto Compute Lod Distances” then in LodX reduce “Screen Size”)

Hey Mach45!
Thanks for the reply, but my problem is not with importing LODs or lightmapping, it’s that UE4 does not allow to set specific lightmap resolution to use per each LOD.
Yes, I can auto-generate lightmap UVs in engine with specified resolution, but that does not mean that the engine will set this resolution to the lightmap texture.
The “lightmap resolution” setting only applies to LOD0. And the other ones - I have no control over it. And that’s frustrating.
So unless I generate LODs in the engine (because then they all use the same lightmap as LOD0), there will be very noticeable pop-ins after light baking because of how vastly different the lighting will be on each LOD.