Linux ToolChain Problem in 4.12

Everytime I try to compile for Linux I get this error

I’ve even tried reinstalling the toolchain and regenerating engine files but still get the same error.

Anyone know the solution to this?

Hey mack32-

Where in the compile process do you encounter this error? Is this during the ./ or ./ or during another step? Can you include what you were doing when you ran into this compile issue?

I get this error when I am compiling a development server on windows for linux. There is no issue with Setup.bat or GenerateProjectFiles.bat.

Can you confirm that the .exe files mentioned in your screenshot are present in the folder path? Did you build Development Editor prior to building Development Server? Also, are you passing any command arguments into the build?

Yes all of the exe files are in the folder, I also did build the development editor before building the development server and I am not passing any command arguments when I compile.

Is there a possible way you guys could try to reproduce the same issue? I even get the same errors with a blank project.

Attempting to compile a project using Development Server as the Solution Configuration and Linux as the Solution Platform worked without error when tested by a team member. We can attempt to test again if you’re able to provide any other information about your setup or compile configurations.

Hi mack32,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.