Download

Limiting the effect of Ambient Cubemap on a material basis?

Hello! I just implemented an ambient cubemap into my environment which improved my lighting and shading.
But I found that with my lighter materials it’s rather extreme in shaded areas.
I tried setting roughness to 1, specular to 0, and metallic to 0. None of them seem to affect how the ambient cubemap is applied to the object, it’s still extremely shiny. How do I control the ambient shine on certain objects?

So I just figured out what the issue is, but not how to solve it. Roughness appears to be broken on some of my materials, and it appears the same whether I set it to 0 or 1, even if I set it to fully rough. Any ideas?

How exactly you implement ambient cubemaps?

By adding a scenecapturecube and applying the resulting cubemap to my post processing’s ambient cubemap.

You gotta show some screenshots to showcase your problem and material setup. :slight_smile:

Alright, so here’s an example without cubemaps enabled:


And here’s one with cubemaps:


As you can see here in my material, my object shouldn’t be shiny like this:

I dont think its possible to exclude objects from the global postprocess effects. One question, why do you need to use the cubemap? What was the problem that made you to use the ambient cubemap?