Download

Lightmaps not loading correctly, degraded in Editor and when playing

Hi Everyone,
I am getting this issue when working on a new files, I manually fixed the lightmaps and the bake turned out well, the problem is the lightmaps aren’t loading as they should
You can see in the attached screen shots there is a degraded lightmap load in the editor and when I press play, I haven’t tried a lauch locally, we do that on my devs machine typically.
I did the
r.Streaming.PoolSize 3000
console command but it changes nothing on Play or in Editor.

Any ideas. I do have a 4096 size lightmap, but only one for the entire walls, ceiling, trim and floors seen in the images so they don’t have artifacts. the rest is 2k or 1k or 512 and there aren’t a
lot of models in this level / scene.

Stats

How it’s loading now, looking bad
Not sure what’s happening, it’s new to me.

This is from the same lightmapping, it just loads like the good or the bad image, mostly bad lately.

I tried the texture streaming console command at 1200, 3000 and 400 and it didn’t help.

The lightmaps are uncompressed, setting compressed didn’t change anything.

Unreal 4.18 with the default Volumetric lightmaps (Which rock when the maps are working!)

Thanks ahead of time

If you wait a minute or do, do the high resolution lightmaps eventually load in?

They don’t load in even after a few minutes, they often get stuck like the bad one. I might just rebake and see what happens, there is a 4K lightmap in the mix, might be causing load problems.

Hi!

Happened to me the same!
I guess you’ve turned off the error/consol(?) messages… you’d see a “TEXTURE STREAMING POOL OVER …” message if you had them on…

Well basically for me didn’t help setting the pool size a lot higher but turning the texture streaming off!!

r.TextureStreaming 0

“This disables the texture streamer. When it is disabled, all texture mips will get fully loaded in memory, even if the texture is never used for rendering. You can toggle this option at runtime, if needed.”

Hope it helps!
Good luck!

Thanks!! I had…That works :slight_smile: We do arch viz so textures should be fine…doing everything on 1080s