Download

Lightmap Dark Spots on Tree Mesh

I have created a tree mesh using Blender’s Add Sapling add-on. It looks fairly good, and I have given it textures, leaves, etc. I also finally got the lightmaps to stop giving the infamous “Overlapping UVs” error. Now the problem is… The final lighting from the lightmaps is terrible. The entire tree is too dark, and some of the leaves are entirely black! I have tried every resolution up to 512, and things have not gone so well. Here is what the tree mesh looks like ingame (256 lightmap resolution):
HighresScreenshot00000.png
(and that’s one of the best angles to view it at. Viewed from shadows, the entire tree is pretty much black!)

Now, the main problem has something to do with the leaves. They are the big issue. I think it might be because they intersect, but there’s nothing I can do about that… :stuck_out_tongue:
Here are the lightmap UVs of the leaves, in case you are interested:
cbc4dd8df742591ee5323c0afa53ed4f64491c10.png

I just haven’t really found a solution to the problem… I really want this tree to look good.

Try this:
https://answers.unrealengine.com/questions/7124/solved-fbx-import-problem-no-smoothing-groups.html

Also, make sure that you that in the World Settings “Force No Precomputed Lighting” is unchecked.
Another good advice would be to set the World settings exactly as they are in the RealisticRendering example project that you can find in the examples tab. Once you get a good bake, try to adjust them to fit your needs.

These things have saved me a lot of trouble.

I’ve formulated an answer to this question.
Check it out here:
https://answers.unrealengine.com/questions/333643/why-are-there-black-spots-on-static-mesh.html