Download

Lighting Woes, and here I thought I was doing ok with lightmaps

Hey guys. Help D:. I’ve redone the lightmap UVs all evening, trying to make sure every pixel is aligned, fiddled with lightmass settings and what not and I keep getting this really strange behavior on my modular, spline-wall tool.

d0bd519a70f9ccc58301befcf125c2ff999baff1.jpeg

I’ve had similar issues on two other spline objects I built but managed to solve them fine with lightmap adjustments. Though they didn’t quite behave like this. They only had the typical black edge band thing going on while these … are more odd.

I know that the lightmass builds maps on separate threads and so on, and that using a modular approach is not a good idea unless you hide the seams etc (from other threads). But I was hoping there were some suggestions :o

Just by a glance there could be two things you could try if you haven’t already.

  1. In your modeling software, try adjusting the smoothing groups so that the angle is under 90, this may help.

  2. Try making a small image in your photo editing software with the following values for RGB: 128, 128, 255. This is what a default/blank normal map would be. Import it as a normal map and plug it into your wall’s material. Then go into your project settings and under the rendering section there should be an option that’s worded somewhat along the lines of “Use normal maps in static lighting calculation” this may help the engine recognize them as flat surfaces.

Thanks for you help, Riley. While neither of it fixed it you did remind me that it looks like a bad smoothing group layout. Even after working on that I just decided to remodel it and make sure I set the groups right. It’s just 7 quads anyway and that fixed the problem. Must have been some gremlins sneaking into the mesh in some fashion but now it looks just fine :). Thanks, still, for your post and reminding me that smoothing groups can really **** things up when they want to XD.