Lighting error

Hello, I am a very new beginner. I’ve been following some tutorials about blueprint where I turn a light on and off using scripts. For some reason when my light is off in the room there is still a yellow hue on the walls. The light itself turns off but the color stays. I haven’t touch materials and I recompiled the scene lighting but for some reason The yellow color stays. Is there any way to get rid of the yellowish color on the walls while the light is turned off?

If your light mobility is set to static or stationary then the engine will bake the lights on static meshes, so the easiest option would be to change your light mobility type to moveable.
You can read more about it here:

Static lights can’t be turned off since they are fully baked, stationary lights have dynamic direct lighting but the indirect lighting is baked so if you turn them off you’ll still see the indirect lighting.