Download

Lighting artifact? Doesn't seem to make sense.

SOLVED! Simply put I thought that the lightmap resolution settings were for the shadow an object was casting but ACTUALLY it’s for the shadow an object is receiving.
Summary of fix: Increased the lightmap resolution of my floor plane. I haven’t looked into switching back to my simple plane just yet; at the moment I’m using a 2k poly plane but I believe with this fix I can move back to my 4 poly plane.
Final Edit: My 4 poly plane worked just fine. No degradation of quality as far as I could tell.

Sorry for the title; just changed it for tagging purposes so that others can easily find this post via a Google search in the future (I hope).

Edit 3,000: Checked just to make sure I’m not a bad reader/Googler. No documentation suggests what I discovered to be true. In fact, UE4 Documentation outright states that the resolution affects the shadows cast by the static mesh. Meaning that the documentation tells me that what I used to think COULD BE true. Epic pls. Less vague.
The wording is currently: Lightmap Resolution allows you to control the detail of the baked lighting that static lights produce.
On Static Mesh Components, lightmap resolution is set either on the Static Mesh asset, or by checking the Override Lightmap Res checkbox and setting the value. Larger values mean higher resolution, but also longer build times and more memory.

It’s just too vague. Spell it out. Shove down my throat exactly what the symptoms of having this be too low or too high are. And DEFINITELY with pictures. Videos would be greatly appreciated even.
Static Lights | Unreal Engine Documentation

These are all the same cube just scaled differently (temporarily while I build out levels; eventually I plan on replacing them with non-scaled cubes of the same size).

To be clear the problem is that the shadows have a weird hook to them.

Additionally, this also happens even with the default cube:

Lightmass settings: https://i.gyazo.com/8853f4874e06353ae90a9290dbfe971e.png

Only lighting is World Direction (settings unchanged from default Third Person Template aside from increasing the Lighting Intensity to 5 as it’s a desert scene).
I do have a post processing volume with GI enabled but it doesn’t affect this bug (just added it trying to fix this problem and it didn’t do anything; confirmed it’s working by making my entire scene red via the scene color)

Additionally, and I’m sorry for tacking this on buuuuut. Is there any way to increase the quality of dynamic shadows such as the cube I’m currently controlling? Just looking into scalabilty and whatnot.

Edit: Looking into this now but I attempted to change the floor from many tiles to a single large tile and shadows GREATLY suffered. I now believe that the problem was simply caused by a larger (scaled) plane in the areas where shadows weren’t looking their best. Going to attempt to add a plane with heavier polycounts and see how it goes. Probably about 4 planes of X size.