Light Shaft Bloom black lines

Black lines in the default map at enable it in the directional light and look at one of the bridges.

This is the map from the Epic games sample Landscape with the same settings but with realtime light and the Light Shaft Bloom setting enabled in the directional light, in the image the sun is at the right, is the bridge near to the lake.

First of All use the Learn Tab → Landscape Mountains make sure you’r using the both in the version 4.12.x(5)

Second open the map and make a clone and save with the name you want, now in that map remove the landscape, and set all lights to total dynamic.(Directional and Skylight)

Now in the directional settings set the max of dynamic cascade shadows and max activate and set too the max of far cascade shadows.

Don’t change nothing more and save.

Enable the Light Shaft Bloom setting the directional light.

That is all now find one of the bridges to check this effect.

Hi Hevedy,

While testing on my end I found that the min roughness on the directional light was set to 0. When I changed it to any value above zero it got rid of the dark areas. Let me know if that fixed the issue on your end. This seems to be a bug dealing with how the engine renders negative roughness values when the directional light’s min roughness is set to 0 or below (negative).

I have logged the issue and created a JIRA: Unreal Engine Issues and Bug Tracker (UE-34426)

Thank you for submitting this bug!

Yeah true the Min Roughness at 0 give this problem, for the temp solution, one thing make sure in the bug report you add “Enable the Light Shaft Bloom” setting the directional light to see the bug in the Steps to Reproduce.

I think the steps you give can be confused with other bug or something, this is related with the pp and the light, no with the materials.

“Open the material and set the roughness to any negative value.” when set it to 0 give already the problem.

Thank you for your input Hevedy,

I was able to reproduce the issue whether or not the light shaft bloom was enabled. The black areas you are seeing is a result of the roughness on the material and how it is interacting with a light source. The repro steps cover the very root of this issue without adding any extra information.