Download

Light maps are my nightmare :/

Hello all :smiley:
Someone with good soul can help me out?

I really suffering a lot with lightmaps, already made 3 times the unwrap uvw, i tried resolution 64 to 1024, build the scene on Production quality and nothing worked and the shadows keep looking like ****… :frowning:

I uploaded the images of the lightmapId and how **** is the shadows are be created!

Someone have any ideas? how to fix?

Well your size of the UV in the different parts is not equal at all, and you can play with the mesh placed in the scene the properties is when overlay the number smaller is bigger so 16 give better result than 64 or that I think. Try that anyway I don’t see a cylinder shape or circle shape in that UV and you have a shape like that.

Thanks for the reply Hevedy, i saw somewhere talking to try to make one single unwrap peer object, maybe was part of my mistake, i have a lot of other props there, but dunno why the desk is beeing chased like that on the Unreal, all the other props are working well…
:confused:

Anyway i will unwrap the cylinder on 2 pass, anyway i need to find more material to study and get really how lightmaps works :slight_smile:

Thanks for the help

Not sure if this will help, but in 3dsmax I think you can add a light map by creating a second “Map Channel” in the unwrap modifier (after creating the second channel, I always switch it back to the first channel). Inside Unreal, in the static mesh editor, you can play with the “min lightmap resolution” to 64 or 128 and set the “lightmap resolution” to 512 in the “Static Mesh Settings”. I hope this piece of information can help somehow.

And within 3ds Max, the Unwrap UV editor has different functions to help pack lightmaps (inc. keeping certain pieces together and proper relative scaling).

Thanks Ivan for the tips, i created the 2 maps ID on 3dsmax, the people here are talking also about the relative scaling, maybe that helps in the lightmap bake situation.
About the resolution i tried to bake with “Min lightmap resolution” and lightmap resolution also… the **** shadows still there, the one thing that makes me upset is that, all the other props are working very good, but the prop that have more planar ground to show, is the only one that is spanking me down hehehe.

So, lets see about the scale :slight_smile:

Thanks also Reidbaker, :slight_smile:

Here’s one test I do with assets to determine what the exact issue is. Sometimes it’s either a UV issue, model issue, or lightmap limitation.

  • Set the lightmap resolution to something large but still reasonable, 256-512 seems to be fine most of the time, but it really depends on your UVs and asset.
  • Scale up the prop x10 or lower the static lighting level scale to something like .1. This will show you if the light mass issues are mostly related to the baking process.
  • If the errors go away and the lighting looks good, the lightmap UVs are fine. That means the object is or has details that are too small/tight to bake well. You can either mess with the lightmap settings or try to approach the asset in a different way.

Generally, objects bake batter if it’s one (or very few) air tight mesh. I think that may be part of the problem.

Hello Zacd, i scalled the object and wow, the problem disappeared with the lightmaps shadows baking process…
So, maybe thats because the object has small details to bake well, right? The funny thing is:
That object is the more clean that i have, even, the object dont have normal map on him, only thing that have, is the chamfer borders :frowning:

What you recommend ? Remake the object?