Light density in Viewport don't coinsides with UV Lightmap

Hello, guys.
I started studying UE a few weeks ago and I have a problem with lighmaps. The thing is lightmap density test texture don’t coinsides with actual UV channel. Take a look at armchair on the pictures attached. As it visible - UV channel is Ok, but density testmap is distributed non uniformly, it is distorted in some way, while on other objects (chair and coffee table) everything looks and bakes right. This wrong distribution causes light (and shadow) bleeding right on the grid’s edges. I used the same steps to create UV channel and import model to UE for all these models, but the problem only occured with armchair. So, maybe someone has faced this kind of issue before and can give me an advise how to overcome it?
Thank you for reading and watching. Looking forward for help.
[Light build result] (
[Lightmap density] (
[UV map] (

Hi Mihendalf,

Looking at your mesh in the scene, something maybe doesn’t seem quite right with everything, particularly in the Lit view from the scene. It looks like I can see the individual faces that make up the chair.

To start off with, make sure that in your static mesh editor when you open the mesh that you’ve set the Lightmap Coordinate Index to 1. This is not the build settings under LOD. You will need to go down to the panel that says “Static Mesh Settings” > and then in Lightmap Coordinate Index set it to 1 if it’s not already.

Also make sure that you’re using a higher lightmap resolution is higher than the default 32 or 64.

Give that a try and let me know if that helps.


Yeah, thanks. I’ve already solved it. The problem was in exporting to FBX. Triangulation of 3DS Max 2015 didn’t perform properly. So I did it manually before exporting, then UV channel wrapped right.

Okay. Cool! Glad you’ve got everything working right. :slight_smile: