Download

Level environment set up fine but now entire scene lightens/ darkens depending on camera position

For some reason, I was in the midst of editing a very simple scene with that had been set up as a night time scene and was working fine. I was trying to edit some static meshes and was adding a post process volume to deal with some lighting and then things went strange. The scene all of a sudden lightened and then I was going down a rabbit hole of fixing it. I finally got the scene right again but now the lighting changes depending on which way you move/ look. I already checked the first person camera auto exposure (which was not on) and turned it on and set min/ max to ,03. I checked for auto exposure in the post process volume and there was none enabled. I am not sure what to do to remedy this.

EDIT: So interestingly enough, when the emissive material is off, it appears the environment is fine, when the emissive material is on, things go dark when you come up close to them.

Thanks,


I think I solved this problem. The thing about UE4 is there are settings EVERYWHERE. I went into the main Project Settings and low and behold, I was able to find under the Default Settings a place to untick Auto Exposure. Things are back to looking half decent again.