Lets make Lightmass EPIC (and understandable)

This is what is happening, it’s bug that isn’t fixed yet:

​​​​​​​

I have a big problem. When I follow all tutorials on how to achieve photorealistic architecture in unreal I don’t get it. It can’t get the soft lightning and shadows. If I have sun light pointing trough the window I got light casting on wall but not reflecting the whole room as it does in real time. Can you help to achieve photo realism.

Post a screen shot. No one can tell what issues you are facing from a simple description.

**SOLVED: I found out my mesh receiving the shadow was scaled and thus causing the bad shadows. Hope this is helpful to anyone else who makes that mistake.

Hi All,

I posted this in answer hub but thought I would try my luck here as well.

I’ve been diving deeper into baked lighting and I’m seeing very low quality shadows produced by static lights. I’ve searched the forums far and wide, I’ve tried all the usual tweaks to remedy them but I’m running out of ideas. My settings seem like they should produce higher quality shadows so I’m wondering if I’m missing something obvious or if it’s a bug.

I made a simple test level using starter and built-in engine content. I’m using 4.18.3, forward renderer on a Mac. Building at higher quality seems to have no effect on the shadow quality. Lightmap compression is off. All the meshes seem to have enough lightmap resolution. Raising it only increases the quality marginally. Raising it too high (to 2048 for the floor) seems to break the light map (it just turns into a smudgy mess).

Hopefully someone may have some ideas for anyone having the same issue as me.

Here are my lightmass settings…

Stationary light lightmap resolution and baked result…


Spotlight lightmap resolution and baked result…


Have you tried to give the light source a “source radius” larger than zero? - This looks pretty bad. Should be better. There is also a pretty visible aliasing on the geometry. I wonder if it is your video card or your general settings.

Test VLM + Sky Lighting Bounces
Use only emmisive textures (50 bounces)
VLM(5;30) + Volume fog
Spheres - moves objects

Test VLM + fog

[QUOTE=
Unreal Engine Project (4.15) for the above test scene - [Dropbox Link]
(Dropbox - File Deleted).

Will be doing some more tests soon with complex projects.
[/QUOTE]

Hello guys, anybody have this file yet?

GoogleDrive
https://docs.google.com/uc?id=0B3wYK…xport=download

Dropbox
https://www.dropbox.com/s/0ljra2l3h0…dNaji.zip?dl=0

Microsoft OneDrive

Mediafire
http://www.mediafire.com/download/9x…arshidNaji.zip

4shared
http://www.4shared.com/zip/8ARByBcice/FarshidNaji.html

Uptobox
http://uptobox.com/s6m3icy2uknu

Thanks for helping the community. Cheers.

2 Likes

I still get that error on 4.19.2 :frowning:

I guess it has yet to be fixed…

I have the same problem. :frowning:

how do I solve it, thanks in advance

Hello everyone, I have a question please … I read a lot of tutorials on for interior architectural visualization you have to set the static lighting level scal to 0.1 and the indirect lighting quality to 10, but is there no access to these two parameters using the GPULIGHTMASS … do I have to switch to light mass CPu to be able to change these are two parameters? … and in the new version of gpulightmass on 4.26 is there access to these two parameters?

Reading through the first part of the GPU lightmass threat I am guessing that it might not use those values. However - You can set those values in the world properties of your level. Better to change it there so you can have different settings in different levels.

I’m getting pretty good results with standard lightmass and settings increased to 0.6 and 2 and increasing the bounces to 5 or 6. Building a map with default values in standard lightmass production mode should give you 90% or more of the quality you would get by increasing the values. Those mentioned values are actually quite extreme and will make your lighting build time extremely long. We are talking more than 10 times longer.

I recommend you start with less extreme values, like 0.75 and 1.5 instead of 0.1 and 10. If you run into problems then slightly increase the values further. Should that not improve the quality then check your lightmaps. Most of the time bad quality is caused by bad light maps and not by those values. - Although increasing them makes sense for archviz. Just maybe not 900%,

missed this thread! Have a question for you guys. Does GPULightmass baked maps work when packaging to Android? I tried lots of attempts and no success. I always get “Rebuild Light” message. Is it a known fact that gpulightmass does not work for packaging to android?

Does the lighting look alright to you on Android? - Because the message might just be a false positive. You can turn it off with a console command: DISABLEALLSCREENMESSAGES

oh no. looks bad. From my attempts only 2 outcomes have shown themselves.
1: Renders the interior but theres dots everywhere like if Brute Force is ON. Can never get it to look better.
2:The whole scene is BLACK like if I have no Lighting at all.

Both do show the Build Lighting message.

Have you tried the standard CPU light mass? Games that won awards for their beautiful levels have been shipped built with it.

At least you would know if it is caused by GPUlightmass or if it is something else. Another test would be to reset all lighting settings to default and see how that goes.

Oh yeah… CPULightmass works great.Ports over just fine. I do the very exact steps but using gpulightmass and it just doesnt work. Even played around with the mobile settings section. ticking on and off items to see if i can find the culprit. but nothing has worked. Wondering if anyone has had any success themselves or is this a known bug?