Download returns an SSL error

Win 10
Ue4 4.22.3
Trying to get to the Unreal Studio online tutorials via the Epic Games Launcher but get an SSL error on Chrome, Avast and Explorer browsers (This site is not secure). The warning allows you to proceed anyway by clicking a link. The link just results in a 403 Forbidden message.

Things I’ve tried:
Resetting the laptop clock.
Adjusting the Chrome flags via chrome://flags/ Seems that option is out of date and doesn’t exist anymore.In explorer editing flags seems to involve getting into the registry. Not too keen on that.
Disabling Avast antivirus.
As mentioned above tried to proceed through the warning.

Been messing with Data Smith, Unreal and Max for a couple of weeks now and its a mindblower! Still its been a while with Ue4 so I thought I would check the tutorials.The launcher behaves perfectly and logs me in automatically every time. All the download and support links are functioning and its only the learning link that is bucking.

Thanks in advance,

Please use for now.
We are in the process of changing the URL. But it hasn’t been changed on the web yet, however the Launcher prematurely had the upcoming link.

This issue is fixed now.


Thanks Stephen.
Indeed it’s working perfectly. Super!