Download

LB_HeightBlend Problem

I followed the docs exactly in setting up my heightblend materials:

And I’m still getting the black material painting with the first layer, TestDirt, that the example image warned against.

7206b8fed910645ec3f4873531b6aed86988e9f4.jpeg

You’ll notice a few things from the screenshot and additionally-

  • The first texture in the Layer Blend material is using Alpha Blend
  • Only using 3 textures total, Max Painted Layers is set to at least 4
  • I tried weighted and non-weighted Layer Info for the Dirt texture
  • I’ve tried setting the Constant Height Input to 1 and 0

Any ideas?

Try LB Weight Blend instead of LB Alpha Blend (as in demo scenes). Worked for me.

Tried that, what demo scenes? The docs specifically mention the first layer should be Alpha Blend.

I had an issue like this. Change the Preview weight to a 1 or 2. See if that does the trick

mat.PNG.jpg

This is the layout I use. I am using the LB Height Blend. Unfortunately I didn’t save or something so I have errors on textures but I was just messing around… Use the RBG for the layer input and the Alpha for the Height input. Do the same for the Normal Map textures