Download

Launching issue on Samsung Galaxy Ace 3

Huston - we have problems here…

Hello to everybody. I have encountered some trouble when tried to launch first person template game on Samsung Galaxy Ace 3 GT-S 7272. After i press Launch Button - launching process begins, but fails on some point with “unknown error”.

Version of my UE: 4.7.4.

TADP was installed succesfully.

Maybe this problem was encountered because my phone doesn’t have Tegra? Or what?

Hi Jandar-man,

Can you give some more details about your issue? You’re launching from your device via the editor’s Launch On button, like this

launch on button.jpg?

When you says your phone doesn’t have Tegra, what do you mean?

Yep! Like this

And by “doesn’t have Tegra” i mean that videocard on my phone is not Nvidia Tegra one. Reason why i pointed on that moment is that TADP is interpretation of Tegra Development Kit. If i’m don’t wrong

And by the way: i have tried all kinds of packaging for android:
Android (All)
ATC
DXT
ETC1
ETC2
PVRTC

But all of them fails. Here is an output log: Output log.docx - Google Drive

Can be my problem in old version of Tadp? Maybe i need to install more fresh v. For now my Tadp version is: tadp-2.0r8

Hi Jandar-Man,

No, that’s the version of TADP that comes with UE4 it being older should not be the problem. I’m seeing this error in your logs:

Have you set up your environment variables when you set up TADP? Here’s the documentation on that.

Yeap - i did. But this error is still pop ups in my logs… Maybe my device don’t supported by engine right now?.. because i can’t see it in device compatibility list… o boy…

The Galaxy Ace 3 runs with the Adreno 305 GPU which UE4 definitely supports. We have a Galaxy S 4 mini GT-i9190 in house, for instance, and it works fine. That error has nothing to do with your specific device.

When you run adb devices from the command line, does it find your device? If it does but you are still having problems, can you try a different USB cable? When adb devices sees your device but UE4 does not, it has typically been a USB cable issue, or a driver conflict, so you might want to check those.

The Ace 3 is a terrible performing device however - does TappyChicken from the Google play store run on that device?

As long as the OS is 2.3 or higher, it should run yes. Here on the Android Device Compatibility wikiyou can see Tappy runs as expected for the Galaxy S4 Mini which has the same GPU (Adreno 305) as the Galaxy Ace 3. I can’t attest to the performance you will get on it, but it should run without crashing or black screen.

That is not to say that everything will, however. That GPU has tested as showing a black screen for any lighting levels higher than LDR.