Landscape texture


I have a landscape and a single texture to cover it all.
When I apply the texture to the landscape, it tiles it thousands of times… I just want it one time, over the entire landscape.

I know this is not the proper way to do a detailed landscape, I’m just learning, and this is a step I need to take.

Can someone point me in the right direction?

Use a landscape layer coord to scale it up:


That worked.

To other newbies who might search and find this thread;

You have 3 things in the material editor for the landscape material. LandscapeLayerCoords, which outputs into the left side of a TextureSample, which goes into the Base Color on the material itself.
Set the Mapping Scale on the coordinates to the resolution of your texture.

Remember to always set the texture mapping scale to the size of your landscape , if you have 2017 landscape , then set mapping scale of your texture to 2017 even if its 4096 resolution it doesn’t matter .

Yes, this is important… I had 4096 set on my 4033 map… it made it a tad better when I fixed this. :slight_smile: Thanks

Now on to remove the shine from the landscape. Any pointers?

Make sure the material is 0 metallic and 1 roughness?

That should do it I believe, from the videos I’ve watched.

You have to set the specular to 0 (constant node)


As a side note… this is so much more logical than Unity.

Cool. This is exactly what I need.

Whaaa…please dont do this :smiley:

I mean you can, but its a hack :smiley: Just make a proper roughness or increase roughness to 0.85 with a constant. Touching Spec is actually not recommended since it does something completely different in pbr than you are used to from traditional shading approaches :wink:

Whilst this is basically true there are some situations where you would need to break the rules.
I found myself setting the specular close to zero (roughness close to 1 at the same time) for a landscape with only basic colors / no normal maps. The ground on this one does not look like grass at all, does it? ://

Yep, same here, I also get a pretty non-realistic result when I do it with roughness and specular -> that’s why I have set the spec to 0 (since the beta I’m doing it like that) :wink:

Why not? A specular exponent of 0 in a Phong-style specular would be “bad” but a specular multiplier of 0 should be fine; it’s just like a black gloss map.
I’d be more concerned with setting roughness to 0 to “turn off” specular – that sounds to me like more of a hack, because you’re still saying “generate a bunch of specular, and then spread it out over an infinitely large highlight area.”
Is there some documentation that suggests why this understanding would be wrong?

What is wrong with this: ://gyazo/0933eb6dfe9e36d30760b6096b1ea1d6 ?

What exactly do you mean? :slight_smile:

When you are not abel to paint onto your landscape, you will have to add landscape layer weights https://docs.unrealengine/latest/INT/Engine/Landscape/Materials/index.html

The only way I’ve seen good results for landscape is by setting spec/metallic to 0, and by setting roughness to/near 1.

What I mean is that it still tiles hundreds of times even with that setup.

Just increase the size -> should be the size of the texture (or even larger) Also use the “LCCT None” as Custom UV Type :slight_smile:

You can multiply coordinates by some small number I think, also here is an issue with painting over the landscape I have run into and found a solution, I hope this helps someone:

If you get black spots all over your terrain where some textures won’t load properly or if you are seeing blocky edges where textures should blend:

change all layers in your layer blend node in your landscape material to weight blend, that makes painting a landscape work as one would intuitively expect more or less.

The above solution works to reduce texture samples to minimum, but the problem with only being able to paint few layers per Component of a landscape actor persists, anyone know a solution? I am getting black spots where the layers blend with more than 3 on a single landscape component. Can I at least make the last applied layer override the lowest one somehow?

This helped except one thing, my texture is not square, how do I set a custom x and y scale?