Download

Landscape Material Problem

I’m working on a level and I’ve got a problem with making a landscape material. When I create a material, and go to its Details, under Usage, to click the “Used with Landscape” check box, I see that it isn’t there. Was it moved, or is there another way to make a landscape material than the way that I taught myself. Because whenever I try to make a landscape material, no matter what I do, the material looks black.

I would suggest you to follow this tutorial: 4. Creating Landscape Materials | Unreal Engine Documentation or the ones on youtube :slight_smile:
As far as I know the “Used with landscape” is not necessary anymore in versions >4.13

Do you get a black material on your landscape or in the viewport of your material editor?
Landscape -> make sure to assign the layers in your landscape tool + paint on your landscape

Response

I get a black material in both my landscape and in the viewport of the material editor, and that tutorial was the first set of instructions that I used when I was making my landscape material and the material was black when I was done. What do you think is the problem when I’m making a landscape material?

-post a pic of your material setup
-have you painted onto the landscape after you have applied the material to it? :slight_smile:

e87c2848ece8d277580b976a7e04f8c2f54ad7f6.jpeg
a6777e0f0f1e3cdd7cc2410071f19b5052b0cea2.jpeg
I also try to paint on the surface but what you see in “landscape” image keeps happening and i think it has to do with the Target layers circled in red.

You need to create layer information so your layers know how to essentially paint on your landscape. What you can do is right-click on one of your existing layers (after creating layer information), and choose the fill layer option in order to get rid of the ‘black’ on your landscape.

That was it! You were right, that was the problem. Thanks for all the help Andrew Hurley!