Landscape - Heightmap import is inaccurate

I’m trying to import a 2048x2048 heightmap that I baked in Blender. When imported, the heightmap does not accurately reflect what I’m getting in Blender. Here are two comparisons:

Notice the “valley” sections. In Blender, these are shallow - as I want them to be. But in Unreal, the valleys are waaaay too steep and deep. This is especially curious, because the mesh I’m showing you in Blender isn’t even the original - that mesh is a representation of the heightmap output. Furthermore, while the valley bits are too deep, the mountainous parts are just right. That is why I am curious about this discrepancy.

Here are my import settings:

Scaling the Z dimensions in UE4 isn’t acceptable because the “mountainous” parts are correct, and that would throw them off.

Any ideas?

Landscape Height Map Resolutions are kind of odd, they’re not power of 2.

Here is a list of Landscape resolutions that sure to work with minimal issues.
8129x8129, 4033x4033, 2017x2017, 1009x1009, 505x505, 253x253, 127x127

See The Landscape Technical Guide for more details.

LMP3D’s post points out how to fix those clamped edges. The forums provided me with the answer to the height problem. For technical reasons, my heightmap needed an inverse Gamma Curve - i.e. a Gamma Curve of 2.2^-1 = 0.454545…