Download

"kinematic bodies with CCD enabled are not supported" error

When I disable physics for an object that has ccd enabled I get this error in the log:

LogPhysics:Error: PHYSX: (d:\ori.cohen_g6217_physics\engine\source hirdparty\physx\physx-3.3\source\physx\src\NpRigidBodyTemplate.h 437) eINVALID_PARAMETER : RigidBody::setRigidBodyFlag: kinematic bodies with CCD enabled are not supported! CCD will be ignored.

Is there a way to suppress it?

Disabling CCD is not an option, because then those objects fall through the floor sometimes.

Pretty sure this is just a 4.12 bug, I’ve got it too despite not using CCD (I even have CCD disabled at the engine level via Preferences).

BTW you don’t want to suppress that error, it will actually prevent cooking/packaging from working entirely if it’s turning up.

OK, managed to disable that annoying error by adding this



if (strcmp(message,"RigidBody::setRigidBodyFlag: kinematic bodies with CCD enabled are not supported! CCD will be ignored.")==0) {
	return; 
}

to FPhysXErrorCallback::reportError()

Does anyone have a better solution?

The most annoying part about this error message is that it breaks cooking :frowning: