Download

JumpPad has unexpected results

I’ve implemented a JumpPad BP, see below. I have placed multiple JumpPads around the scene, and set the force amount to 500, 1000, 1500 etc… Using vanilla ThirdPerson Character, I run over my jump pads and expect the player to pushed into the air according to the force set. The BP works but is inconsistent. Not all the JumpPads work as expected, with very little force being applied, or sometimes huge amounts! The gravity is default and I haven’t messed with any Character Physics properties. What the hell is going on?

Use the “Launch Character” node instead of “Add Impulse” and enable the override Z checkbox on it.

Thanks dude, it is now working as expected. I do have a query about the forces. Since using the LaunchCharacter node I have had to increase the force amount to achieve the same ‘expected’ height/result when using Add Impulse node. I’m curious as to why LaunchCharacter requires a bigger number to achieve the same result as Add Impulse? Any ideas?

Thanks for your help.