Download

Jump Animation Sequence - Can't See Necessary Nodes

Hi guys,

I’ve been following this tutorial on setting up character animations and I’m stuck on the jump animation:

https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/CharacterMovement/Blueprints/AnimBlueprint_Jump/index.html

Specifically in step 5, it’s saying I should grab the TimeRemaining for my animation, but none of those nodes show up in my context menu (neither in nor out of context). I can’t seem to figure out what I’m doing wrong.

Just type in “time remaining”. Then it should appear. Otherwise disable “context sensitive” :slight_smile:

Also make sure that you have used your animation in one of the states

Tried all of that. The only thing I see that makes any sense is Get Timer Remaining Time, which has Object Reference (anim sequence) and Function Name (string) inputs. It outputs a float, which is ultimately what I need, but do I need to put anything into the Function Name input? I can select the animation Object easy enough.

Are you sure that you have the animation dragged into your state? That screwed me over a few times.

No, you shouldnt use that -> as Pabooklas mentioned, double check if you really have an animation in your state :slight_smile:

That’s what I thought at first. After double checking, I have animations in both the source and destination states. Could it be that one of them is a blend space? I’m currently trying to go from the state with an Anim Instance to the state with a Blend Space.

Quick edit: I tried removing the blend space and adding another anim instance and that still didn’t fix the issue.

If the animation is there and you tried with and without context sensitive, I am out of ideas :slight_smile:

As you already realized, it should also work with blendspaces -> as I see from the image you have copied the state? What happens when you just recreate it? (probably then you will be abel to get the time remain ration). I tried out some stuff, but in my case it somehow works all the time :frowning:

Ahh the _Copy is from moving the animation itself and saving as a copy. That’s simply the animation’s name, not that it’s a copied state. I’ve also posted in Unreal Answers, so hopefully we can come to a resolution.

https://answers.unrealengine.com/questions/133046/jump-animation-sequence-cant-see-necessary-nodes-i.html

:smiley: Ok, now I run out of ideas. Could you probably upload your anim bp (when it is possible also the animations) so that we can take a look at it?

@Zooch plug your state machine into the final node and compile, then you should see the time-remaining in the statemachine conditions

had this problem about a year ago :wink:

Oh man, points to you sir! This was indeed the problem.

Thanks everyone!